Project

General

Profile

Bug #21870

app logger dies when an exception is thrown

Added by Tomer Brisker almost 3 years ago. Updated over 2 years ago.

Status:
Duplicate
Priority:
High
Assignee:
-
Category:
Logging
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

e.g:

2017-12-05T17:00:01 04361f9b [app] [F] ActionController::RoutingError (No route matches [GET] "/webpack/76a6a26daafa41b512cc.hot-update.json"):
2017-12-05T17:00:01 04361f9b [app] [F]   
2017-12-05T17:00:01 04361f9b [app] [F] lib/middleware/tagged_logging.rb:18:in `call'

after this no [app] logs are shown until the server is restarted.


Related issues

Has duplicate Foreman - Refactor #22354: Make SilencedLogger thread safeClosed2018-01-22

History

#1 Updated by Lukas Zapletal almost 3 years ago

I am unable to reproduce, but can you retest with this patch reverted:

0126b62d6e0bb9fc893c56d7349f17d7e32ae60f

#2 Updated by Tomer Brisker almost 3 years ago

I tried reverting this patch but it still occurs.
This occurs on Rails 5 with ruby 2.4.

#3 Updated by Tomer Brisker over 2 years ago

#4 Updated by Tomer Brisker over 2 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF