Project

General

Profile

Bug #2190

Failed to destroy a compute instance ActiveRecord::RecordNotFound

Added by Jason Ashby over 9 years ago. Updated over 9 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Compute resources
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

I'm working on getting Foreman to manage my entire build cycle. Anyhoo, I've got some hosts that Foreman created on my VMware vCenter server that I can't seem to Delete in the Foreman web GUI. When I click Delete for the host, I get:

Failed to remove jasontest.mydomain.com from the autosign file: 406 Not Acceptable

I have to autosign entries whatsoever. Now, when I click Unmanage Host in Foreman, I get the following when I try to Delete:

Failed to destroy a compute myvcenterhost (VMWare) instance jasontest.mydomain.com: ActiveRecord::RecordNotFound

Which may be because I deleted the corresponding VM directly from vCenter.

The build was kind of in limbo (the VM was created in VMware vcenter, but no OS was installed yet), so I clicked Cancel Build at one point. Lemme know if you need more info here.

Oh I'm running Foreman 1.1RC5 on CentOS 6.3 and using Firefox 18 when working in the foreman gui.


Related issues

Is duplicate of Foreman - Bug #2161: Cannot delete a host if the compute resource VM is already deletedClosed2013-01-28

History

#1 Updated by Jason Ashby over 9 years ago

typo: "I have to autosign entries whatsoever" should read "I have no autosign entries whatsoever".

#2 Updated by Ohad Levy over 9 years ago

  • Status changed from New to Duplicate

this was fixed after RC5

Also available in: Atom PDF