Project

General

Profile

Bug #22160

schema 2 tag not showing related tags

Added by Thomas McKay over 4 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Container
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Viewing an individual tag that refers to a digest that other tags also refer to should have the related_tags field in json reflect that.

To reproduce:
+ sync registry-1.docker.io busybox
+ view the manifests for the repo and note that 1.25-glibc and 1.25.1-glibc refer to the same digest (works as expected)
+ click through 1.25-glibc and inspect json (/api/v2/docker_tags/52)
+ note that the related_tags only refers to 1.25-glibc and not 1.25.1-glibc

History

#1 Updated by Thomas McKay over 4 years ago

  • Status changed from New to Rejected

This is not a bug. The related_tags are referencing the same tag across multiple environments and is working correctly. I had not added the repo to a CV or LCE which is why it was blank.

#2 Updated by Justin Sherrill over 4 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF