Project

General

Profile

Bug #22392

after changing http proxy pulp importers use old setting till service restart

Added by Chris Roberts over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Installer
Target version:

Description

Description of problem:
After changing http proxy settings by installer the new settings are effective only in katello (cdn scan, repo enable, insights...) while in pulp (repo sync) the old settings are still in effect till next service restart.

The installer is probably missing to ensure a restart of some/all pulp services.
The issue is a regression against Sat6.2

Version-Release number of selected component (if applicable):
Satellite 6.3 Beta

How reproducible:
deterministic

Steps to Reproduce:
1. Run installer to force SAT to communicate over http proxy
2. Trigger CDN reposet scan or repository enablement and watch traffic actually hittng http proxy
3. Trigger a repo sync and watch traffic not hitting proxy

Workaround:
4. Restart services (particularly Pulp ones)
5. Trigger a repo sync and watch traffic finally hitting proxy

Actual results:
very illusory result since only some of actions are actually using new http proxy settings

Expected results:
after installer run all actions should use new proxy http settings

Associated revisions

Revision cd36eaee (diff)
Added by Chris Roberts over 2 years ago

Fixes #22392 - add restart on config change

History

#1 Updated by The Foreman Bot over 2 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/puppet-pulp/pull/300 added

#2 Updated by Justin Sherrill over 2 years ago

  • Legacy Backlogs Release (now unused) set to 339

#3 Updated by The Foreman Bot over 2 years ago

  • Pull request https://github.com/theforeman/puppet-pulp/pull/304 added

#4 Updated by Chris Roberts over 2 years ago

  • % Done changed from 0 to 100
  • Status changed from Ready For Testing to Closed

#5 Updated by The Foreman Bot over 2 years ago

  • Pull request https://github.com/Katello/katello-installer/pull/606 added

Also available in: Atom PDF