Project

General

Profile

Bug #23233

satellite-installer --katello-pulp-max-speed leads to broken pulp

Added by Chris Roberts about 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Installer
Target version:
Difficulty:
trivial
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from BZ:

Description of problem:
using
  1. satellite-installer --katello-pulp-max-speed 10MB
    leaves pulp broken

Version-Release number of selected component (if applicable):
satellite-6.3.0.1-1.el7sat.noarch

How reproducible:

Steps to Reproduce:
1. install satellite 6.3 as per documentation
2. try to add speed limitation: # satellite-installer --katello-pulp-max-speed 10MB
3. afterwards pulp is not working anymore:
  1. hammer ping
    candlepin:
    Status: ok
    Server Response: Duration: 17ms
    candlepin_auth:
    Status: ok
    Server Response: Duration: 21ms
    pulp:
    Status: FAIL
    Server Response:
    pulp_auth:
    Status: FAIL
    foreman_tasks:
    Status: ok
    Server Response: Duration: 490ms

#

Actual results:
pulp broken because of wrongly set value in /etc/pulp/server/plugins.conf.d/yum_importer.json

  1. cat /etc/pulp/server/plugins.conf.d/yum_importer.json {

    "proxy_host": null,

    "proxy_port": null,

    "proxy_username": null,

    "proxy_password": null,

    "max_speed": 10485760"

} #

--> there are " missing in front of the value

Expected results:
should add value in a way that it is supported

Additional info:

changing "max_speed": 10485760"
to "max_speed": "10485760"
and restarting satellite makes it work again

Associated revisions

Revision 045dedfd (diff)
Added by Chris Roberts about 3 years ago

Fixes #23233 - update yum_max_speed example with valid to_bytes format (#315)

History

#1 Updated by The Foreman Bot about 3 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/puppet-pulp/pull/315 added

#2 Updated by Justin Sherrill about 3 years ago

  • Legacy Backlogs Release (now unused) set to 338

#3 Updated by Chris Roberts about 3 years ago

  • % Done changed from 0 to 100
  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF