Project

General

Profile

Bug #23238

hammer hostgroup info --output json returns json including non unique keys

Added by Ales Dujicek over 1 year ago. Updated about 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Host groups
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

there is "Operating System" twice and they contain different data
so one of them is lost if you parse it

# hammer --output json -v -u admin -p changeme  hostgroup info --id="36" 
{
  "Id": 36,
  "Name": "6lLfrO",
  "Title": "6lLfrO",
  "Operating System": {
    "content_source_id": 1,
    "content_source_name": "foreman.redhat.com",
    "content_view_id": 371,
  },
  "Puppet CA Proxy": {
    "content_source_id": 1,
    "content_source_name": "foreman.redhat.com",
    "content_view_id": 371,
  },
  "Puppet Master Proxy": {
  },
  "Network": {
  },
  "Operating system": {
    "Architecture": {
      "content_source_id": 1,
      "content_source_name": "foreman.redhat.com",
      "content_view_id": 371
    }
  },
  "Puppetclasses": [
  ],
  "Parameters": [
    null
  ],
  "Organizations": [
  ],
  "OpenSCAP Proxy": null,
  "Content View": {
    "ID": 371,
    "Name": "SQyJYkoRsU" 
  },
  "Lifecycle Environment": {
    "ID": 265,
    "Name": "rjPGjE" 
  },
  "Content Source": {
    "ID": 1,
    "Name": "sforeman.redhat.com" 
  },
  "Kickstart Repository": {
    "ID": 566,
    "Name": "NSZjjWCFkVaaVuF" 
  }
}

foreman-1.18.0-0.develop.201804061848git210e295.el7.noarch
tfm-rubygem-hammer_cli-0.13.pre.develop-1.201803232224gite493035.el7.noarch


Related issues

Related to Hammer CLI - Tracker #14914: Tracker for output related issuesNew2016-05-03

Is duplicate of Hammer CLI - Bug #23722: output of hammer hostgroup info contains redundant info about operating systems Closed

History

#1 Updated by Tomáš Strachota over 1 year ago

  • Category set to Host groups

#2 Updated by Tomáš Strachota over 1 year ago

#3 Updated by Ales Dujicek over 1 year ago

  • Bugzilla link set to 1596504

#4 Updated by Tomáš Strachota about 1 year ago

  • Status changed from New to Duplicate

#5 Updated by Tomáš Strachota about 1 year ago

  • Is duplicate of Bug #23722: output of hammer hostgroup info contains redundant info about operating systems added

Also available in: Atom PDF