Project

General

Profile

Bug #23463

YAML rendering of external nodes generates incorrect data if hashes are used

Added by Henry Spanka 5 months ago. Updated 3 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Smart Variables
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Rendering the external YAML data of a host causes Foreman to generate incorrect data if it includes hashes that are set in parameterised classes.

Generated YAML:

classes:
  easystack:
    ceph_monitors:
    - !ruby/hash:ActiveSupport::HashWithIndifferentAccess
      fqdn: [RETRACTED]
      ip:  [RETRACTED]
      master: true
    - !ruby/hash:ActiveSupport::HashWithIndifferentAccess
      fqdn:  [RETRACTED]
      ip:  [RETRACTED]
      master: true
    - !ruby/hash:ActiveSupport::HashWithIndifferentAccess
      fqdn:  [RETRACTED]
      ip:  [RETRACTED]
      master: true

This seems to be a duplicate of #9240 and was introduced again somewhere between 1.16.1 and 1.17.0.


Related issues

Is duplicate of Foreman - Bug #23382: Editing Smart Class Parameter of type YAML creates malformed value in release 1.17.0Closed2018-04-24

History

#1 Updated by Michael Moll 5 months ago

  • Related to Bug #23382: Editing Smart Class Parameter of type YAML creates malformed value in release 1.17.0 added

#2 Updated by Tomer Brisker 4 months ago

  • Legacy Backlogs Release (now unused) set to 360

#3 Updated by Tomer Brisker 4 months ago

  • Category changed from API to Smart Variables

#4 Updated by Daniel Lobato Garcia 3 months ago

  • Triaged set to No

Does anyone have a good reproducer for this one? I'm able to get the following hashes right:

classes:
  dhcp:
    bootfiles:
      '00:06': grub2/bootia32.efi
      '00:07': grub2/bootx64.efi
      '00:09': grub2/bootx64.efi

#5 Updated by Daniel Lobato Garcia 3 months ago

  • Status changed from New to Duplicate

This is most certainly a duplicate of #23382

#6 Updated by Daniel Lobato Garcia 3 months ago

  • Related to deleted (Bug #23382: Editing Smart Class Parameter of type YAML creates malformed value in release 1.17.0)

#7 Updated by Daniel Lobato Garcia 3 months ago

  • Is duplicate of Bug #23382: Editing Smart Class Parameter of type YAML creates malformed value in release 1.17.0 added

Also available in: Atom PDF