Project

General

Profile

Bug #23543

Package[foreman-proxy] foreman 1.16 and 1.17 install failure due to rubygem-rkerberos depends not found

Added by Stephen Cooke 3 months ago. Updated 4 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Packaging
Target version:
Difficulty:
medium
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

p5foreman: /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/util/command_line.rb:73:in `execute'
p5foreman: /opt/puppetlabs/puppet/bin/puppet:5:in `<main>'
p5foreman: /Stage[main]/Foreman_proxy::Install/Package[foreman-proxy]/ensure: change from 'purged' to 'present' failed: Execution of '/bin/yum -d 0 -e 0 -y install fore
man-proxy' returned 1: Error: Package: rubygem-rkerberos-0.1.3-6.el7.x86_64 (epel)
p5foreman: Requires: libkadm5clnt_mit.so.11(kadm5clnt_mit_11_MIT)(64bit)
p5foreman: Package: rubygem-rkerberos-0.1.3-6.el7.x86_64 (epel)
p5foreman: Requires: libkadm5clnt_mit.so.11()(64bit)
p5foreman: You could try using --skip-broken to work around the problem

History

#1 Updated by Stephen Cooke 3 months ago

I have noticed that fresh installs on Centos7.4 of foreman1.16 or above are failing due to 'foreman-proxy' returned 1: Error: Package: rubygem-rkerberos-0.1.3-6.el7.x86_64 (epel)
p5foreman: Requires: libkadm5clnt_mit.so.11(kadm5clnt_mit_11_MIT)(64bit)
p5foreman: Package: rubygem-rkerberos-0.1.3-6.el7.x86_64 (epel)
p5foreman: Requires: libkadm5clnt_mit.so.11()(64bit)

Where can I find a working version of "libkadm5clnt_mit.so" that will work or a version of "rubygem-rkerberos" that doesnt need it, or a version of foreman that dont need either.

my stable release of foreman 1.15, doesnt have this issue

#2 Updated by Stephen Cooke 3 months ago

Stephen Cooke wrote:

I have noticed that fresh installs on Centos7.4 of foreman1.16 or above are failing due to 'foreman-proxy' returned 1: Error: Package: rubygem-rkerberos-0.1.3-6.el7.x86_64 (epel)
p5foreman: Requires: libkadm5clnt_mit.so.11(kadm5clnt_mit_11_MIT)(64bit)
p5foreman: Package: rubygem-rkerberos-0.1.3-6.el7.x86_64 (epel)
p5foreman: Requires: libkadm5clnt_mit.so.11()(64bit)

Where can I find a working version of "libkadm5clnt_mit.so" that will work or a version of "rubygem-rkerberos" that doesnt need it, or a version of foreman that dont need either.

my stable release of foreman 1.15, doesnt have this issue

https://bugzilla.redhat.com/show_bug.cgi?id=1330431

This issue is not fixed in RHE till 7.5 comes out, can some provide a workaround for everyone not using RHE7.5

having the older version of rubygem-rkerberos in a foreman repo may be a temp solution

#3 Updated by Dmitri Dolguikh 3 months ago

  • Tracker changed from Bug to Support

#4 Updated by Stephen Cooke 3 months ago

  • Difficulty set to medium
  • Tracker changed from Support to Bug

Stephen Cooke wrote:

Stephen Cooke wrote:

I have noticed that fresh installs on Centos7.4 of foreman1.16 or above are failing due to 'foreman-proxy' returned 1: Error: Package: rubygem-rkerberos-0.1.3-6.el7.x86_64 (epel)
p5foreman: Requires: libkadm5clnt_mit.so.11(kadm5clnt_mit_11_MIT)(64bit)
p5foreman: Package: rubygem-rkerberos-0.1.3-6.el7.x86_64 (epel)
p5foreman: Requires: libkadm5clnt_mit.so.11()(64bit)

Where can I find a working version of "libkadm5clnt_mit.so" that will work or a version of "rubygem-rkerberos" that doesnt need it, or a version of foreman that dont need either.

my stable release of foreman 1.15, doesnt have this issue

https://bugzilla.redhat.com/show_bug.cgi?id=1330431

This issue is not fixed in RHE till 7.5 comes out, can some provide a workaround for everyone not using RHE7.5

having the older version of rubygem-rkerberos in a foreman repo may be a temp solution

I would like to answer my own question, please leave this available for others. The following repo can resolve "CentOS-CR.repo"

#5 Updated by Stephen Cooke 3 months ago

rubygem-rkerberos-0.1.3-5.el7.x86_64 : A Ruby interface for the the Kerberos library( this one works)
rubygem-rkerberos-0.1.3-6.el7.x86_64 : A Ruby interface for the the Kerberos library( this one breaks it)

#6 Updated by Tomer Brisker about 2 months ago

  • Legacy Backlogs Release (now unused) changed from 296 to 360

#7 Updated by Tomer Brisker 20 days ago

  • Category changed from Smart proxies to Packaging
  • Project changed from Foreman to Smart Proxy

#8 Updated by Ewoud Kohl van Wijngaarden 4 days ago

  • Triaged set to No
  • Status changed from New to Resolved

By now 7.5 has been out for a while and the issue should be solved.

Also available in: Atom PDF