Project

General

Profile

Bug #24341

on smartproxies, calls to api/v2/ are no passed to upstream foreman server

Added by Hart Mel about 3 years ago. Updated almost 3 years ago.

Status:
Duplicate
Priority:
High
Assignee:
-
Category:
-
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

After having added custom content like CentOS mirrors with GPG keys in Katello, using this repositories by hosts behind smartproxies fail because GPG keys cannot be retrieved.

URLs like https://smartproxy.mydomain.com/katello/api/v2/repositories/15/gpg_key_content are failing because they are not configured in apache.

Files : 05-pulp-https.conf and pulp_ostree.conf have configuration for URLs which look like /katello/api/repositories, without the "v2" strings. I duplicated the configuration lines and added "v2" in URLs and package installation is working.


Related issues

Is duplicate of Katello - Bug #24316: Smart proxy missing GPG key (ProxyPass missing)Closed

History

#1 Updated by Andrew Kofink about 3 years ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.7.1
  • Priority changed from Normal to High

#2 Updated by Andrew Kofink about 3 years ago

  • Is duplicate of Bug #24316: Smart proxy missing GPG key (ProxyPass missing) added

#3 Updated by Andrew Kofink about 3 years ago

  • Status changed from New to Duplicate

#4 Updated by Ondřej Levý almost 3 years ago

  • Found in Releases Katello 3.9.0 added
  • Found in Releases deleted (Katello 3.7.0)

Hi,
this bug was closed without any fix and same bug is still in version Katello 3.9.

Also available in: Atom PDF