Project

General

Profile

Bug #24488

Help rendering fails

Added by Marek Hulán 4 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Hammer core
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Team Backlog:
Found in Releases:

Description

This seems to be a regression caused by #18532, resource is a class method.

Associated revisions

Revision abcaff4a (diff)
Added by Marek Hulán 3 months ago

Fixes #24488 - restore help building (#280)

History

#1 Updated by The Foreman Bot 4 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/hammer-cli/pull/280 added

#2 Updated by Marek Hulán 4 months ago

  • Bugzilla link set to 1611004

#3 Updated by Martin Bacovsky 4 months ago

The description of the problem is not entirely correct. The resource as an instance method is present. What is actually going on there is that when the resource is missing in API it is set to nil and warning is printed. Later when we are asking for the resource assigned to the command we see the nil and try to ask the parent command which is the MainCommand for the top level commands. The MainCommand is not child of ApipieCommand and has no resource assigned and this is the place where the original error comes from "Error: undefined method `resource' for HammerCLI::MainCommand:Class".

#4 Updated by Anonymous 3 months ago

  • Status changed from Ready For Testing to Closed

#5 Updated by Martin Bacovsky 3 months ago

  • Fixed in Releases hammer-cli 0.14.0 added

#6 Updated by Martin Bacovsky 3 months ago

  • Fixed in Releases hammer-cli 0.13.1 added

Also available in: Atom PDF