Project

General

Profile

Bug #24592

content hosts registered after 3.8RC upgrade doesn't show repository sets

Added by Hart Mel almost 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Repositories
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:

Description

After upgrade to Katello 3.8RC1, newly registered content hosts doesn't show any repository sets in web user interface. The consequence is that after adding products to a host, repository tuning to enable/disable is unavailable.

Hosts registered previously to the 3.8RC1 upgrade still show the repositories in the repository sets tab.
Registration has been tested with and without activation keys.

repositorysets.png View repositorysets.png 14.5 KB Hart Mel, 08/13/2018 09:06 AM
subscriptions.png View subscriptions.png 54.2 KB Hart Mel, 08/13/2018 09:06 AM
showall.png View showall.png 24.4 KB Hart Mel, 08/16/2018 06:25 PM
actikey.png View actikey.png 27.2 KB Hart Mel, 08/16/2018 06:25 PM
contenthost2.png View contenthost2.png 61.6 KB Hart Mel, 08/16/2018 06:25 PM
contenthost.png View contenthost.png 50 KB Hart Mel, 08/16/2018 06:25 PM
Repositorysets Subscriptions Showall Actikey Contenthost2 Contenthost

Associated revisions

Revision 1de3a99c (diff)
Added by sjha4 almost 2 years ago

Fixes #24592 - Repository sets not displayed

History

#1 Updated by Jonathon Turel almost 2 years ago

  • Target version set to Katello 3.8.0
  • Status changed from New to Needs design

#2 Updated by Samir Jha almost 2 years ago

Hello Hart, Are both the screenshots from content host UI or the activation key UI?
Also, do you see the subscriptions on the key attached to the registered host and is auto-attach enabled on activation key?

#3 Updated by Hart Mel almost 2 years ago

Both screenshots come from content host UI. Autoattach is set to "yes" on key. I see the subscriptions on the keys.
In repository set tab, on one host which have this problem, when I click "show all", I see nothing. On another host, when I click "show all", I see all repositories.
I registered them with the bootstrap.py script (maybe the version from github master, I m not sure).
I can try any test that you would suggest.

#4 Updated by Samir Jha almost 2 years ago

This might be because when auto-attach is set, only the subscriptions required to satisfy the system's installed products are attached. You can verify the difference between subscriptions on the 2 content hosts and see why some repository-sets are not displayed. If you add the subscriptions manually, you should be able to see the repository-sets being added as well.

One problem I see is the show all checkbox not actually showing all repository-sets. I will check if that is a change in behavior or a regression.

#5 Updated by Hart Mel almost 2 years ago

When I compare a host OK and a host not OK, I see no difference in subscriptions, activation key or autoattach settings. Both have their products in the list.

I removed all the subscriptions from host which had empty repository sets, and I added subscriptions again. Repository set stays empty.

I removed all the subscriptions from host which was OK, and repository sets are still there. Then I check "Limit to lifecycle environment" and repository sets are still there. (maybe it s the normal behavior, I dont know)

#6 Updated by Hart Mel almost 2 years ago

I do not reproduce on a 3.8 fresh install with host registered with subscription-manager. (while the origin problem is on a system in 3.7 updated to 3.8 with host registered through bootstrap.py)

#7 Updated by The Foreman Bot almost 2 years ago

  • Status changed from Needs design to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/7635 added

#8 Updated by Samir Jha almost 2 years ago

Hello Hart,

I have one test for you. Could you please refresh the repository-sets page on the not ok host and then check show all. I believe this is a UI issue and just need to verify the behavior I am seeing in my setup.

#9 Updated by Samir Jha almost 2 years ago

  • Triaged changed from No to Yes
  • Assignee set to Samir Jha

#10 Updated by Hart Mel almost 2 years ago

On a host registered after 3.8 upgrade : after a browser refresh while being on repository sets tab, it s empty. I check "show all" and I see ALL the products and repositories of the organization. The ones which were in the activation key used to register host have their correct enable/disable overriden statuses.
Then I click something else, like the "Traces" tab and click back to repository sets. "Show all" is now unchecked, then I check it again, and the list is still empty.

On a host registered before 3.8 upgrade, I do not reproduce the repository sets tab behavior : When switching to repository set tab, I see only the subscribed product. When I check the "show all" box, I still see only subscribed products.

#11 Updated by The Foreman Bot almost 2 years ago

  • Pull request https://github.com/Katello/katello/pull/7652 added

#12 Updated by Samir Jha almost 2 years ago

  • Target version changed from Katello 3.8.0 to Katello 3.8.1

#13 Updated by Hart Mel almost 2 years ago

I applied the changes from the 2 pull requests and restarted httpd, but problem is still present. Is it possible that something went wrong during upgrade ?

#14 Updated by Samir Jha almost 2 years ago

Hart Mel wrote:

I applied the changes from the 2 pull requests and restarted httpd, but problem is still present. Is it possible that something went wrong during upgrade ?

The bastion change is the one which should fix this. My understanding is that on a page refresh the page behaves as it should.. But when you move to a different tab and return, the show all behaves incorrectly.. Is that correct? That is the issue I saw in my box and that is what is being fixed..

#15 Updated by Samir Jha almost 2 years ago

  • Pull request https://github.com/Katello/bastion/pull/230 added
  • Pull request deleted (https://github.com/Katello/katello/pull/7635)

#16 Updated by Anonymous almost 2 years ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF