Bug #2540


Error retriving "Virtual Machines" list from Rackspace compute resource.

Added by Jim Bailey almost 11 years ago. Updated over 10 years ago.

Sam Kottler
Compute resources
Target version:
Fixed in Releases:
Found in Releases:


I get the following error when clicking on the "Virtual Machines" tab for a Rackspace compute resource "There was an error listing VM's : 500 OK"

In the production.log, I get the following error.

Started GET "/compute_resources/1-rackspace-lon/vms" for at Wed May 22 08:48:42 +0000 2013
Processing by ComputeResourcesVmsController#index as HTML
Parameters: {"compute_resource_id"=>"1-rackspace-lon"}
Operation FAILED: wrong number of arguments (1 for 0)
Rendered common/500.rhtml (16.8ms)
Completed 500 Internal Server Error in 175ms (Views: 18.1ms | ActiveRecord: 10.8ms)


rackspace_500.png View rackspace_500.png 14.7 KB Sam Kottler, 07/21/2013 10:06 PM
Actions #1

Updated by Ohad Levy almost 11 years ago

  • Status changed from New to Need more information

did you figure this one out?
any chance you are using the V2 api (e.g. openstack) instead of the V1?

Actions #2

Updated by Jim Bailey almost 11 years ago

I have tried V1 V2 and the Openstack and Rackspace commute resources type; same error for all of them. I can login but It doesn't let me see the compute resources. If I can get it to work I try and get some docs written up since the Manual is a bit sparse there. We actually use both EC2 and Rackspace, so I might actually be bale to help the project for a change.

Actions #3

Updated by Sam Kottler almost 11 years ago

  • File rackspace_500.png rackspace_500.png added
  • Category set to Compute resources
  • Status changed from Need more information to New
  • Assignee set to Sam Kottler
  • Target version set to 1.3.0
  • Difficulty set to easy

I've also run into this issue. It happens when using the v2 API (the only one foreman supports ;)).

Attached is a screenshot. I'll work on fixing this.

Actions #4

Updated by Sam Kottler almost 11 years ago

  • Status changed from New to Ready For Testing

I submitted a PR to fog to fix the issue upstream that just got merged thanks to @Ohad Levy -

There is an open PR for Foreman, too, although it'll require some changes before it's ready to get merged - Once the new Fog release comes out we can pin to versions above 1.15.0 and remove the hack that'll get implemented in lib/ as a stopgap right now.

Actions #5

Updated by Sam Kottler over 10 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF