Project

General

Profile

Bug #25660

Content credential repo page is broken

Added by John Mitsch almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Content Credentials
Target version:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1653792

Description of problem:

1) Search functionality just doesn't work no matter what data you put into the field
2) Page contain three empty rows for `SSL CA Cert`, `SSL Client Cert` and `SSL Client Key` which cannot be interacted in any way

If empty entities are expected, please confirm

Version-Release number of selected component (if applicable):
6.5.0

How reproducible:
Always

Steps to Reproduce:
1. Create valid gpg key
2. Assign key to valid yum repository
3. Open gpg key entity
4. Select 'Repositories' tab
5. Try to search for any entity

Actual results:
Search functionality doesn't work and page contains weird empty entities

Expected results:
Search functionality works as intended

Additional info:
Search request looks good:

2018-11-27T17:07:08 [I|app|] Started GET "/katello/api/v2/content_credentials/3?organization_id=77&page=1&paged=true&per_page=20&search=test" for xxxxxxxxx at 2018-11-27 17:07:08 +0100

2018-11-27T17:07:08 [I|app|878a0] Processing by Katello::Api::V2::ContentCredentialsController#show as JSON

2018-11-27T17:07:08 [I|app|878a0] Parameters: {"organization_id"=>"77", "page"=>"1", "paged"=>"true", "per_page"=>"20", "search"=>"test", "api_version"=>"v2", "id"=>"3"}

2018-11-27T17:07:09 [I|app|878a0] Current user set to admin (admin)

2018-11-27T17:07:09 [I|app|878a0] Rendering /opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.9.0/app/views/katello/api/v2/content_credentials/show.json.rabl within katello/api/v2/layouts/resource

2018-11-27T17:07:09 [I|app|878a0] Rendered /opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.9.0/app/views/katello/api/v2/content_credentials/show.json.rabl within katello/api/v2/layouts/resource (13.2ms)

2018-11-27T17:07:09 [I|app|878a0] Completed 200 OK in 19ms (Views: 10.8ms | ActiveRecord: 4.4ms)

Associated revisions

Revision 6eee848d (diff)
Added by John Mitsch almost 2 years ago

Fixes #25660 - Content credential page search

  • Fixes #25660 - Content credential page search

This fix does many things:
- Update the rabl template for content credentials to use the
correct renamed methods.
- Update the rabl template for content credentials to use root
repositories. This way the user isn't returned all repositories
from content views, rather just the library instance.
- Update the javascript functions to build the product and repo
list to give to display on the page.
- Since we don't use the 'repositories' endpoint for gpg keys,
I added a simple UI filter for the repo and product pages in
content credential pages.

To test, create gpg keys and add to repos and products. It helps
if those repos are in content views to ensure that the CV repos
aren't showing up in the results. Check the content credential
detail page and ensure the product and repo associations listed
are correct.

  • Refs #25660 - changed to use mapping and added tests

History

#1 Updated by The Foreman Bot almost 2 years ago

  • Assignee set to John Mitsch
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/7878 added

#2 Updated by John Mitsch almost 2 years ago

  • Status changed from Ready For Testing to Closed

#3 Updated by Jonathon Turel almost 2 years ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.10.0

#4 Updated by The Foreman Bot almost 2 years ago

  • Pull request https://github.com/Katello/katello/pull/7890 added

#5 Updated by The Foreman Bot almost 2 years ago

  • Pull request https://github.com/Katello/katello/pull/7893 added

#6 Updated by The Foreman Bot almost 2 years ago

  • Pull request https://github.com/Katello/katello/pull/7894 added

Also available in: Atom PDF