Project

General

Profile

Bug #25834

Error when uploading a manifest file on the disconnected Server

Added by John Mitsch over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Subscriptions
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1663021

Description of problem:

Error while uploading the manifest file to the disconnected Server using the hammer command.

How reproducible:

Always

Steps to Reproduce:

1. Upload the manifest file via hammer command.

Actual results: Error -

Error: Validation failed: Environments expecting environments used by hosts or inherited (check mismatches report)., Domains expecting domains used by hosts or inherited (check mismatches report)., Media expecting media used by hosts or inherited (check mismatches report)., Compute resources expecting compute resources used by hosts or inherited (check mismatches report)., ApplicationRecord|Capsules expecting capsules used by hosts or inherited (check mismatches report)., Ptables expecting ptables used by hosts or inherited (check mismatches report).

Expected results:

Manifest upload successful

Additional info:

Please refer the following BZ - https://bugzilla.redhat.com/show_bug.cgi?id=1582221. This bugzilla shows to be in a POST state, however, an errata has been release for it.

Talked to beav, who advised to open a new BZ and provide the reference to the above BZ.

Associated revisions

Revision 8fb1cc5d (diff)
Added by John Mitsch over 2 years ago

Fixes #25834 - Skip org validations on all manifest tasks (#7919)

  • Fixes #25834 - Skip org validations on all manifest tasks

This was originally introduced here:
https://github.com/Katello/katello/pull/7402

The change was made for manifest refresh, but the users are still
facing the same issue on import and deleting a manifest. This commit
DRYs it up and skips the validation for all manifest actions.

It's not the best solution, but the alternative is fixing the compl
ex relationships in taxonomies and their inconsistencies, which I know
we have had larger discussions about and taxonomies is pretty tightly
coupled to everything else in our app. I think it would be highly
unlikely that a manifest audit would cause any invalid transactions
so this seems like a realistic solution.

I'm open to other suggestions, but since we introduced this pattern
elsewhere and it's blocking major actions in Katello, I think we
should skip validations for all manifest actions and then potentially
discuss larger changes in this area.

History

#1 Updated by John Mitsch over 2 years ago

  • Description updated (diff)
  • Subject changed from Error when uploading a manifest file on the disconnected Satellite Server to Error when uploading a manifest file on the disconnected Server

#2 Updated by The Foreman Bot over 2 years ago

  • Assignee set to John Mitsch
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/7919 added

#3 Updated by John Mitsch over 2 years ago

  • Status changed from Ready For Testing to Closed

#4 Updated by Andrew Kofink over 2 years ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.12.0

Also available in: Atom PDF