Project

General

Profile

Bug #26075

arch and release for RHEL8 does not seem right on "Sync Status" page

Added by John Mitsch over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Repositories
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1672593

Description of problem:
Arch and release for RHEL8 does not seem right on "Sync Status" page

Steps to Reproduce:
1. Attempt to sync RHEL8 GA repos from Stage and observe how Content -> Sync Status page looks like

Actual results:
I can see 2 issues:
1) There are two variants of the kickstarts - with release "8" and "8.0". There should be only one.
2) No mater what RHEL8 arch you choose, repos are all marked as "noarch" - I would expect x86_64 / ppc64le / aarch64

Expected results:
Release and arch is correct.

Additional info:
See screenshots please

Associated revisions

Revision 36cd944e (diff)
Added by John Mitsch over 2 years ago

Fixes #26075 - RHEL8 on Sync Status Page

  • Fixes #26075 - RHEL8 on Sync Status Page

RHEL8 includes arches inside of the URL path, not
passed in as substitutions to replace `$arch`.

We handle displaying the arch in the UI by parsing
the path to check for an arch if no arch is given.

That change can be seen
[here](https://github.com/Katello/katello/pull/7938/files)

The issue is that the derived arch isn't passed back
when enabling the repo. So you wind up with 'noarch'
for that repo. This can be seen on the sync status
page.

This change passes back the derived arch if no
substituted arch is found. This is then stored
when creating the repo, and can be seen on pages
like 'sync status'

The logic in creating the path with substitutions had
to be altered a bit as it will error if 'basearch' is
passed and there is no $basearch to replace in the path.

To review:
- enable a RHEL8 repo
- go to sync status page and make sure its listed under
the actual arch of the repo

History

#1 Updated by John Mitsch over 2 years ago

  • Description updated (diff)

#2 Updated by The Foreman Bot over 2 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/7982 added

#3 Updated by Chris Roberts over 2 years ago

  • Target version set to Katello 3.12.0

#4 Updated by Chris Roberts over 2 years ago

  • Triaged changed from No to Yes

#5 Updated by John Mitsch over 2 years ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF