Project

General

Profile

Actions

Bug #2680

closed

Unable to provisioning host using UI - vSphere 4.1.0

Added by Lucas E Holm almost 11 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Host creation
Target version:
Difficulty:
medium
Triaged:
Fixed in Releases:
Found in Releases:

Description

Hi,

Im unable to provision a new host using UI - vSphere 4.1.0.

Please let me know if there is a known solution.

FOREMAN: 1.2.0
RUBY: ruby 1.8.7 (2011-06-30 patchlevel 352) [x86_64-linux]
PUPPET: 3.2.2
Started POST "/hosts/compute_resource_selected" for 10.8.0.42 at 2013-06-19 14:43:55 +0000
Processing by HostsController#compute_resource_selected as */*
  Parameters: {"utf8"=>"✓", "authenticity_token"=>"4riyLz3XRAgbpaNiTm5o4iH/uC2heApoYhodDezNR8U=", "host"=>{"name"=>"newhostname", "compute_resource_id"=>"1", "hostgroup_id"=>"", "environment_id"=>"", "managed"=>"true", "progress_report_id"=>"[FILTERED]", "type"=>"Host::Managed", "mac"=>"", "domain_id"=>"", "ip"=>"", "interfaces_attributes"=>{"new_interfaces"=>{"_destroy"=>"false", "type"=>"Nic::Managed", "mac"=>"", "name"=>"", "domain_id"=>"", "ip"=>"", "provider"=>"IPMI"}}, "architecture_id"=>"", "provision_method"=>"build", "build"=>"1", "disk"=>"", "root_pass"=>"[FILTERED]", "is_owned_by"=>"", "enabled"=>"1", "model_id"=>"", "comment"=>"", "overwrite"=>"false"}}
  [1m[35mUser Load (0.4ms)[0m  SELECT "users".* FROM "users" WHERE "users"."id" = $1 LIMIT 1  [["id", 1]]
Setting current user thread-local variable to admin
  [1m[36mOrganization Load (0.3ms)[0m  [1mSELECT "taxonomies".* FROM "taxonomies" WHERE "taxonomies"."type" IN ('Organization') AND "taxonomies"."id" IS NULL LIMIT 1[0m
  [1m[35mLocation Load (0.2ms)[0m  SELECT "taxonomies".* FROM "taxonomies" WHERE "taxonomies"."type" IN ('Location') AND "taxonomies"."id" IS NULL LIMIT 1
Setting current organization thread-local variable to none
Setting current location thread-local variable to none
  [1m[36mComputeResource Load (0.3ms)[0m  [1mSELECT "compute_resources".* FROM "compute_resources" WHERE "compute_resources"."id" = 1 ORDER BY compute_resources.name LIMIT 1[0m
  [1m[35mComputeResource Exists (0.5ms)[0m  SELECT 1 AS one FROM "compute_resources" WHERE ("compute_resources"."name" = 'dmzhoster' AND "compute_resources"."id" != 1) LIMIT 1
  Rendered compute_resources_vms/form/_vmware.html.erb (39.8ms)
  Rendered hosts/_compute.html.erb (547.5ms)
Setting current location thread-local variable to none
Setting current organization thread-local variable to none
Operation FAILED: undefined method `stringify_keys' for #<RbVmomi::VIM:0x000000096d1e48>

Files

ui_foreman_host_new.png View ui_foreman_host_new.png 43.8 KB Lucas E Holm, 06/19/2013 11:07 AM
production.log production.log 88.9 KB Lucas E Holm, 06/19/2013 11:07 AM
foreman-install.log foreman-install.log 5.41 KB Lucas E Holm, 06/19/2013 11:07 AM
production_after_patch.log production_after_patch.log 23.3 KB Lucas E Holm, 06/19/2013 11:47 AM
tmp-log.txt tmp-log.txt 3.18 KB Lucas E Holm, 06/19/2013 01:30 PM
1-new_compute_resource.PNG View 1-new_compute_resource.PNG 27 KB Ben Fairless, 07/15/2013 04:33 AM
2-vsphere_instance_list.PNG View 2-vsphere_instance_list.PNG 15 KB Ben Fairless, 07/15/2013 04:33 AM
3-new_host.PNG View 3-new_host.PNG 38.9 KB Ben Fairless, 07/15/2013 04:33 AM
4-virtual_machine_error.PNG View 4-virtual_machine_error.PNG 10.1 KB Ben Fairless, 07/15/2013 04:33 AM
5-esxi_host_instance_list.PNG View 5-esxi_host_instance_list.PNG 51.2 KB Ben Fairless, 07/15/2013 04:43 AM
foreman-debug-MX9bY.tar.xz foreman-debug-MX9bY.tar.xz 68.3 KB Xavier ROUX, 11/06/2013 04:56 PM

Related issues 4 (0 open4 closed)

Related to Foreman - Bug #2612: VirtualMachine Tab empty when trying to create VM using fog 1.8.0-3 or 1.11.1ClosedDominic Cleal06/04/2013Actions
Related to Foreman - Bug #8619: undefined method `stringify_keys' for #<RbVmomi::VIM ..>Resolved12/09/2014Actions
Related to Foreman - Bug #10336: foreman-rake prints "Workaround for RbVmomi may not work as ComputeResource is already loaded: #{ComputeResource}"ClosedDominic Cleal04/30/2015Actions
Has duplicate Foreman - Bug #3612: Editing host after an compute associate ends in an oopsDuplicate11/08/2013Actions
Actions #1

Updated by Dominic Cleal almost 11 years ago

  • Status changed from New to Feedback

Is this an RPM or Debian installation? If it's an RPM one, can you please apply this update and patch, then test again?

http://koji.katello.org/koji/getfile?taskID=39206&name=ruby193-rubygem-rbvmomi-1.6.0-1.el6.noarch.rpm
https://github.com/theforeman/foreman/pull/730.patch

Both came from #2612 and will part of RC3, needed to fix a few VMware build issues.

Actions #2

Updated by Lucas E Holm almost 11 years ago

CentOS RPM installation. I applied both and got similar result. Please see attached log. Thanks.

Actions #3

Updated by Dominic Cleal almost 11 years ago

Could you try something a little hacky please?

edit /opt/rh/ruby193/root/usr/share/gems/gems/rbvmomi-1.6.0/lib/rbvmomi/deserialization.rb and on line 183, change it to this, adding a single line in:

     elsif t == BasicTypes::ManagedObjectReference
       File.open("/tmp/log", "a") { |f| f.write("type: #{xml['type']}, obj: #{@conn.type(xml['type'])}, ancestors: #{@conn.type(xml['type']).ancestors}\n") }
       @conn.type(xml['type']).new @conn, xml.text

Then re-test and attach /tmp/log?

Actions #4

Updated by Lucas E Holm almost 11 years ago

Went ahead and did the magic, but unfortunately same result. /tmp/log attached.

Actions #5

Updated by Dominic Cleal almost 11 years ago

  • Status changed from Feedback to Assigned

Thanks Lucas, that debug contained all the info I needed.

This is very similar to #2612 in that rbvmomi is finding the "ComputeResource" class from Foreman rather than its own "ComputeResource" class and then failing.

Actions #6

Updated by Dominic Cleal almost 11 years ago

  • Assignee changed from Dominic Cleal to Anonymous
Actions #7

Updated by Dominic Cleal almost 11 years ago

Relevant code:
https://github.com/vmware/rbvmomi/blob/master/lib/rbvmomi/deserialization.rb#L185
(this tries to load the string "ComputeResource", see the /tmp/log file above)

https://github.com/vmware/rbvmomi/blob/master/lib/rbvmomi/connection.rb#L211
(this instantiates it using const_get, which must be loading our ComputeResource instead)

Actions #8

Updated by Anonymous almost 11 years ago

Lucas Ursin-Holm: how easily can you reproduce this? I assume this happens after Foreman restart and stays like that? Are you running in rails development or production environment? If it's easier for you, we can chat on the irc: I'm witlessb on #theforeman and #theforeman-dev.

Actions #9

Updated by Dominic Cleal almost 11 years ago

  • Status changed from Assigned to Need more information
Actions #10

Updated by Dominic Cleal almost 11 years ago

  • Target version deleted (1.2.0)
Actions #11

Updated by Ben Fairless almost 11 years ago

I have the same issue, using VMware 5.1

I can post error logs if necessary, although it sounds like you guys have already identified the issue.

Actions #12

Updated by Anonymous almost 11 years ago

Could you post steps to reproduce this and conditions under which this error occurs? I couldn't reproduce the issue in our lab.

Updated by Ben Fairless almost 11 years ago

Using Foreman version 1.2.0 downloaded onto Red Hat Enterprise Linux 6.4 from the official repositories. Our VMware vCenter is running version 5.1.0, Rbvmobi is version 1.6.0 and Fog is version 1.11.1.

As you can see from the uploaded screenshots, Fog has no problem logging into the VMware host initially and is able to get the correct fingerprint. However it is not able to display a list of machines currently running on the host.

In screenshot 3, as soon as you select 'Deploy on' and choose the VMware host the 'Virtual Machine' tab appears and then goes red. Screenshot 4 displays the (not particularly helpful) error message.

Actions #14

Updated by Ben Fairless almost 11 years ago

Also, this is not a problem if I log into the VMware host machine itself, where everything appears to work fine. This problem is related only to vSphere vCenter.

Actions #15

Updated by Ben Fairless almost 11 years ago

I spoke too soon. When you log directly into the host machine, the list of Virtual Machines is displayed (which does not happen with the vSphere). However, the 'Virtual Machine' tab still produces the same error on attempting to provisiona new machine.

Actions #16

Updated by Ben Fairless over 10 years ago

Operation FAILED: undefined method `stringify_keys' for #<RbVmomi::VIM:0x0000000879fab0>

This appears in production.log when I select VMware from the 'Deploy On' dropdown.

Actions #17

Updated by Anne Hopkins over 10 years ago

Has any further progress been made on this issue? Any further information needed?

I get the same error when adding a Host and choosing 'Deploy On' to VMWare ESXi 5.1.0.

Log snippet:

Rendered compute_resources_vms/form/_vmware.html.erb (235.8ms)
Rendered hosts/_compute.html.erb (524.2ms)
Operation FAILED: undefined method `stringify_keys' for #&lt;RbVmomi::VIM:0x007f94590700e0&gt;
Rendered common/500.html.erb (4.3ms)
Completed 500 Internal Server Error in 536ms (Views: 4.7ms | ActiveRecord: 0.2ms)
Actions #18

Updated by Xavier ROUX over 10 years ago

Hello,

I have the same issue on a new install.

OS: CentOS 6.4
Puppet: 3.3.1 from PuppetLabs repo
Foreman: 1.3.0 from Foreman repo
Installation of Foreman and Puppet with foreman-installer-1.3.0
Add foreman-vmware-1.3.0 from Foreman repo
Foreman uses its default postgrey database in production environment

VMWare ESXi-5.0.0

The Virtual Machines appear correctly from "Compute Ressources" page in Provisionning menu.

When I create a new host and I select "Deploy on": "ESX-Neos" then the tab "Virtual Machine" becomes red with this error: "Internal Server Error"

In production.log :

Started POST "/hosts/compute_resource_selected" for 172.16.70.169 at 2013-11-06 17:44:13 +0100
Processing by HostsController#compute_resource_selected as */*
  Parameters: {"utf8"=>"â", "authenticity_token"=>"hLhZkG8KcHUwc+FlVENY6dRIv1Rx+HWPn3vngw5gTlQ=", "host"=>{"name"=>"", "hostgroup_id"=>"", "compute_resource_id"=>"1", "environment_id"=>"", "puppet_ca_proxy_id"=>"", "puppet_proxy_id"=>"", "managed"=>"true", "progress_report_id"=>"[FILTERED]", "type"=>"Host::Managed", "mac"=>"", "domain_id"=>"", "ip"=>"", "interfaces_attributes"=>{"new_interfaces"=>{"_destroy"=>"false", "type"=>"Nic::Managed", "mac"=>"", "name"=>"", "domain_id"=>"", "ip"=>"", "provider"=>"IPMI"}}, "architecture_id"=>"", "provision_method"=>"build", "build"=>"1", "disk"=>"", "root_pass"=>"[FILTERED]", "is_owned_by"=>"", "enabled"=>"1", "model_id"=>"", "comment"=>"", "overwrite"=>"false"}}
  User Load (0.3ms)  SELECT "users".* FROM "users" WHERE "users"."id" = $1 LIMIT 1  [["id", 1]]
Setting current user thread-local variable to admin
  Organization Load (0.3ms)  SELECT "taxonomies".* FROM "taxonomies" WHERE "taxonomies"."type" IN ('Organization') AND "taxonomies"."id" IS NULL LIMIT 1
  Location Load (0.3ms)  SELECT "taxonomies".* FROM "taxonomies" WHERE "taxonomies"."type" IN ('Location') AND "taxonomies"."id" IS NULL LIMIT 1
Setting current organization thread-local variable to none
Setting current location thread-local variable to none
  ComputeResource Load (0.4ms)  SELECT "compute_resources".* FROM "compute_resources" WHERE "compute_resources"."id" = 1 ORDER BY compute_resources.name LIMIT 1
  ComputeResource Exists (0.3ms)  SELECT 1 AS one FROM "compute_resources" WHERE ("compute_resources"."name" = 'ESX-Neos' AND "compute_resources"."id" != 1) LIMIT 1
  Rendered compute_resources_vms/form/_vmware.html.erb (151.4ms)
  Rendered hosts/_compute.html.erb (214.1ms)
Setting current location thread-local variable to none
Setting current organization thread-local variable to none
Operation FAILED: undefined method `stringify_keys' for #<RbVmomi::VIM:0x007ff1a4ff33c0>
/opt/rh/ruby193/root/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/attribute_assignment.rb:69:in `assign_attributes'
/opt/rh/ruby193/root/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/base.rb:498:in `initialize'
/opt/rh/ruby193/root/usr/share/gems/gems/rbvmomi-1.6.0/lib/rbvmomi/deserialization.rb:183:in `new'
/opt/rh/ruby193/root/usr/share/gems/gems/rbvmomi-1.6.0/lib/rbvmomi/deserialization.rb:183:in `deserialize'
/opt/rh/ruby193/root/usr/share/gems/gems/rbvmomi-1.6.0/lib/rbvmomi/deserialization.rb:162:in `block in deserialize'
/opt/rh/ruby193/root/usr/share/gems/gems/rbvmomi-1.6.0/lib/rbvmomi/deserialization.rb:162:in `map'
/opt/rh/ruby193/root/usr/share/gems/gems/rbvmomi-1.6.0/lib/rbvmomi/deserialization.rb:162:in `deserialize'
/opt/rh/ruby193/root/usr/share/gems/gems/rbvmomi-1.6.0/lib/rbvmomi/deserialization.rb:174:in `block in deserialize'
/opt/rh/ruby193/root/usr/share/gems/gems/nokogiri-1.5.6/lib/nokogiri/xml/node_set.rb:239:in `block in each'
/opt/rh/ruby193/root/usr/share/gems/gems/nokogiri-1.5.6/lib/nokogiri/xml/node_set.rb:238:in `upto'
/opt/rh/ruby193/root/usr/share/gems/gems/nokogiri-1.5.6/lib/nokogiri/xml/node_set.rb:238:in `each'
/opt/rh/ruby193/root/usr/share/gems/gems/rbvmomi-1.6.0/lib/rbvmomi/deserialization.rb:170:in `deserialize'
/opt/rh/ruby193/root/usr/share/gems/gems/rbvmomi-1.6.0/lib/rbvmomi/deserialization.rb:174:in `block in deserialize'
/opt/rh/ruby193/root/usr/share/gems/gems/nokogiri-1.5.6/lib/nokogiri/xml/node_set.rb:239:in `block in each'
/opt/rh/ruby193/root/usr/share/gems/gems/nokogiri-1.5.6/lib/nokogiri/xml/node_set.rb:238:in `upto'
/opt/rh/ruby193/root/usr/share/gems/gems/nokogiri-1.5.6/lib/nokogiri/xml/node_set.rb:238:in `each'
/opt/rh/ruby193/root/usr/share/gems/gems/rbvmomi-1.6.0/lib/rbvmomi/deserialization.rb:170:in `deserialize'
/opt/rh/ruby193/root/usr/share/gems/gems/rbvmomi-1.6.0/lib/rbvmomi/connection.rb:68:in `block in parse_response'
/opt/rh/ruby193/root/usr/share/gems/gems/rbvmomi-1.6.0/lib/rbvmomi/connection.rb:68:in `map'
/opt/rh/ruby193/root/usr/share/gems/gems/rbvmomi-1.6.0/lib/rbvmomi/connection.rb:68:in `parse_response'
/opt/rh/ruby193/root/usr/share/gems/gems/rbvmomi-1.6.0/lib/rbvmomi/connection.rb:90:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/rbvmomi-1.6.0/lib/rbvmomi/basic_types.rb:203:in `_call'
/opt/rh/ruby193/root/usr/share/gems/gems/rbvmomi-1.6.0/lib/rbvmomi/basic_types.rb:74:in `block (2 levels) in init'
/opt/rh/ruby193/root/usr/share/gems/gems/rbvmomi-1.6.0/lib/rbvmomi/basic_types.rb:183:in `_get_property'
/opt/rh/ruby193/root/usr/share/gems/gems/rbvmomi-1.6.0/lib/rbvmomi/basic_types.rb:35:in `block (2 levels) in init'
/opt/rh/ruby193/root/usr/share/gems/gems/fog-1.15.0/lib/fog/vsphere/requests/compute/list_clusters.rb:14:in `raw_clusters'
/opt/rh/ruby193/root/usr/share/gems/gems/fog-1.15.0/lib/fog/vsphere/requests/compute/list_clusters.rb:8:in `list_clusters'
/opt/rh/ruby193/root/usr/share/gems/gems/fog-1.15.0/lib/fog/vsphere/models/compute/clusters.rb:15:in `all'
/opt/rh/ruby193/root/usr/share/gems/gems/fog-1.15.0/lib/fog/core/collection.rb:141:in `lazy_load'
/opt/rh/ruby193/root/usr/share/gems/gems/fog-1.15.0/lib/fog/core/collection.rb:22:in `empty?'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_view/helpers/form_options_helper.rb:588:in `to_select_tag'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_view/helpers/form_options_helper.rb:157:in `select'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_view/helpers/form_options_helper.rb:642:in `select'
/usr/share/foreman/app/helpers/layout_helper.rb:108:in `block in selectable_f'
/usr/share/foreman/app/helpers/layout_helper.rb:130:in `block (2 levels) in field'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_view/helpers/capture_helper.rb:40:in `block in capture'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_view/helpers/capture_helper.rb:187:in `with_output_buffer'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_view/helpers/capture_helper.rb:40:in `capture'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_view/helpers/tag_helper.rb:95:in `content_tag'
/usr/share/foreman/app/helpers/layout_helper.rb:129:in `block in field'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_view/helpers/capture_helper.rb:40:in `block in capture'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_view/helpers/capture_helper.rb:187:in `with_output_buffer'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_view/helpers/capture_helper.rb:40:in `capture'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_view/helpers/tag_helper.rb:95:in `content_tag'
/usr/share/foreman/app/helpers/layout_helper.rb:124:in `field'
/usr/share/foreman/app/helpers/layout_helper.rb:107:in `selectable_f'
/usr/share/foreman/app/views/compute_resources_vms/form/_vmware.html.erb:5:in `_app_views_compute_resources_vms_form__vmware_html_erb___1676832231301556305_70337912650140'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_view/template.rb:145:in `block in render'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/notifications.rb:125:in `instrument'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_view/template.rb:143:in `render'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_view/renderer/partial_renderer.rb:265:in `render_partial'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_view/renderer/partial_renderer.rb:238:in `block in render'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_view/renderer/abstract_renderer.rb:38:in `block in instrument'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/notifications.rb:123:in `block in instrument'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/notifications/instrumenter.rb:20:in `instrument'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/notifications.rb:123:in `instrument'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_view/renderer/abstract_renderer.rb:38:in `instrument'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_view/renderer/partial_renderer.rb:237:in `render'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_view/renderer/renderer.rb:41:in `render_partial'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_view/renderer/renderer.rb:15:in `render'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_view/helpers/rendering_helper.rb:24:in `render'
/usr/share/foreman/app/views/hosts/_compute.html.erb:4:in `block in _app_views_hosts__compute_html_erb__2217096130425522334_69999640'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_view/helpers/capture_helper.rb:40:in `block in capture'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_view/helpers/capture_helper.rb:187:in `with_output_buffer'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_view/helpers/capture_helper.rb:40:in `capture'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_view/helpers/form_helper.rb:607:in `fields_for'
/usr/share/foreman/app/views/hosts/_compute.html.erb:1:in `_app_views_hosts__compute_html_erb__2217096130425522334_69999640'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_view/template.rb:145:in `block in render'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/notifications.rb:125:in `instrument'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_view/template.rb:143:in `render'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_view/renderer/partial_renderer.rb:265:in `render_partial'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_view/renderer/partial_renderer.rb:238:in `block in render'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_view/renderer/abstract_renderer.rb:38:in `block in instrument'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/notifications.rb:123:in `block in instrument'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/notifications/instrumenter.rb:20:in `instrument'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/notifications.rb:123:in `instrument'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_view/renderer/abstract_renderer.rb:38:in `instrument'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_view/renderer/partial_renderer.rb:237:in `render'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_view/renderer/renderer.rb:41:in `render_partial'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_view/renderer/renderer.rb:15:in `render'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/abstract_controller/rendering.rb:110:in `_render_template'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_controller/metal/streaming.rb:225:in `_render_template'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/abstract_controller/rendering.rb:103:in `render_to_body'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_controller/metal/renderers.rb:28:in `render_to_body'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_controller/metal/compatibility.rb:50:in `render_to_body'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/abstract_controller/rendering.rb:88:in `render'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_controller/metal/rendering.rb:16:in `render'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_controller/metal/instrumentation.rb:40:in `block (2 levels) in render'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/core_ext/benchmark.rb:5:in `block in ms'
/opt/rh/ruby193/root/usr/share/ruby/benchmark.rb:295:in `realtime'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/core_ext/benchmark.rb:5:in `ms'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_controller/metal/instrumentation.rb:40:in `block in render'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_controller/metal/instrumentation.rb:83:in `cleanup_view_runtime'
/opt/rh/ruby193/root/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/railties/controller_runtime.rb:24:in `cleanup_view_runtime'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_controller/metal/instrumentation.rb:39:in `render'
/usr/share/foreman/app/controllers/hosts_controller.rb:131:in `block in compute_resource_selected'
/usr/share/foreman/app/models/taxonomy.rb:55:in `block (2 levels) in as_taxonomy'
/usr/share/foreman/app/models/concerns/foreman/thread_session.rb:143:in `as_location'
/usr/share/foreman/app/models/taxonomy.rb:54:in `block in as_taxonomy'
/usr/share/foreman/app/models/concerns/foreman/thread_session.rb:108:in `as_org'
/usr/share/foreman/app/models/taxonomy.rb:53:in `as_taxonomy'
/usr/share/foreman/app/controllers/hosts_controller.rb:130:in `compute_resource_selected'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_controller/metal/implicit_render.rb:4:in `send_action'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/abstract_controller/base.rb:167:in `process_action'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_controller/metal/rendering.rb:10:in `process_action'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/abstract_controller/callbacks.rb:18:in `block in process_action'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:549:in `block (3 levels) in _run__465092147706093094__process_action__819735105344631194__callbacks'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:215:in `block in _conditional_callback_around_4553'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:326:in `around'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:310:in `_callback_around_743'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:214:in `_conditional_callback_around_4553'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:526:in `block (2 levels) in _run__465092147706093094__process_action__819735105344631194__callbacks'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:215:in `block in _conditional_callback_around_4552'
/usr/share/foreman/app/models/concerns/foreman/thread_session.rb:33:in `clear_thread'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:214:in `_conditional_callback_around_4552'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:415:in `block in _run__465092147706093094__process_action__819735105344631194__callbacks'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:215:in `block in _conditional_callback_around_4551'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:326:in `around'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:310:in `_callback_around_13'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:214:in `_conditional_callback_around_4551'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:414:in `_run__465092147706093094__process_action__819735105344631194__callbacks'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:405:in `__run_callback'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:385:in `_run_process_action_callbacks'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:81:in `run_callbacks'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/abstract_controller/callbacks.rb:17:in `process_action'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_controller/metal/rescue.rb:29:in `process_action'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_controller/metal/instrumentation.rb:30:in `block in process_action'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/notifications.rb:123:in `block in instrument'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/notifications/instrumenter.rb:20:in `instrument'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/notifications.rb:123:in `instrument'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_controller/metal/instrumentation.rb:29:in `process_action'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_controller/metal/params_wrapper.rb:207:in `process_action'
/opt/rh/ruby193/root/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/railties/controller_runtime.rb:18:in `process_action'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/abstract_controller/base.rb:121:in `process'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/abstract_controller/rendering.rb:45:in `process'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_controller/metal.rb:203:in `dispatch'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_controller/metal/rack_delegation.rb:14:in `dispatch'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_controller/metal.rb:246:in `block in action'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/routing/route_set.rb:73:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/routing/route_set.rb:73:in `dispatch'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/routing/route_set.rb:36:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/journey-1.0.4/lib/journey/router.rb:68:in `block in call'
/opt/rh/ruby193/root/usr/share/gems/gems/journey-1.0.4/lib/journey/router.rb:56:in `each'
/opt/rh/ruby193/root/usr/share/gems/gems/journey-1.0.4/lib/journey/router.rb:56:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/routing/route_set.rb:600:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/apipie-rails-0.0.23/lib/apipie/static_dispatcher.rb:56:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/middleware/best_standards_support.rb:17:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/rack-1.4.1/lib/rack/etag.rb:23:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/rack-1.4.1/lib/rack/conditionalget.rb:35:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/middleware/head.rb:14:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/middleware/params_parser.rb:21:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/middleware/flash.rb:242:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/rack-1.4.1/lib/rack/session/abstract/id.rb:205:in `context'
/opt/rh/ruby193/root/usr/share/gems/gems/rack-1.4.1/lib/rack/session/abstract/id.rb:200:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/middleware/cookies.rb:339:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/query_cache.rb:64:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/connection_adapters/abstract/connection_pool.rb:473:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/middleware/callbacks.rb:28:in `block in call'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:405:in `_run__514499275219926981__call__4593317503708142472__callbacks'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:405:in `__run_callback'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:385:in `_run_call_callbacks'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:81:in `run_callbacks'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/middleware/callbacks.rb:27:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/middleware/remote_ip.rb:31:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/middleware/debug_exceptions.rb:16:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/middleware/show_exceptions.rb:56:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/railties-3.2.8/lib/rails/rack/logger.rb:26:in `call_app'
/opt/rh/ruby193/root/usr/share/gems/gems/railties-3.2.8/lib/rails/rack/logger.rb:16:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/middleware/request_id.rb:22:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/rack-1.4.1/lib/rack/methodoverride.rb:21:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/rack-1.4.1/lib/rack/runtime.rb:17:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/cache/strategy/local_cache.rb:72:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/rack-1.4.1/lib/rack/lock.rb:15:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_dispatch/middleware/static.rb:62:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/rack-cache-1.2/lib/rack/cache/context.rb:136:in `forward'
/opt/rh/ruby193/root/usr/share/gems/gems/rack-cache-1.2/lib/rack/cache/context.rb:143:in `pass'
/opt/rh/ruby193/root/usr/share/gems/gems/rack-cache-1.2/lib/rack/cache/context.rb:155:in `invalidate'
/opt/rh/ruby193/root/usr/share/gems/gems/rack-cache-1.2/lib/rack/cache/context.rb:71:in `call!'
/opt/rh/ruby193/root/usr/share/gems/gems/rack-cache-1.2/lib/rack/cache/context.rb:51:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/railties-3.2.8/lib/rails/engine.rb:479:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/railties-3.2.8/lib/rails/application.rb:223:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/railties-3.2.8/lib/rails/railtie/configurable.rb:30:in `method_missing'
/opt/rh/ruby193/root/usr/share/gems/gems/rack-1.4.1/lib/rack/builder.rb:134:in `call'
/opt/rh/ruby193/root/usr/share/gems/gems/rack-1.4.1/lib/rack/urlmap.rb:64:in `block in call'
/opt/rh/ruby193/root/usr/share/gems/gems/rack-1.4.1/lib/rack/urlmap.rb:49:in `each'
/opt/rh/ruby193/root/usr/share/gems/gems/rack-1.4.1/lib/rack/urlmap.rb:49:in `call'
/usr/lib/ruby/gems/1.8/gems/passenger-4.0.5/lib/phusion_passenger/rack/thread_handler_extension.rb:77:in `process_request'
/usr/lib/ruby/gems/1.8/gems/passenger-4.0.5/lib/phusion_passenger/request_handler/thread_handler.rb:140:in `accept_and_process_next_request'
/usr/lib/ruby/gems/1.8/gems/passenger-4.0.5/lib/phusion_passenger/request_handler/thread_handler.rb:108:in `main_loop'
/usr/lib/ruby/gems/1.8/gems/passenger-4.0.5/lib/phusion_passenger/request_handler.rb:441:in `block (3 levels) in start_threads'
  Rendered common/500.html.erb (8.5ms)
Completed 500 Internal Server Error in 232ms (Views: 9.3ms | ActiveRecord: 0.3ms)
Actions #19

Updated by Dominic Cleal over 10 years ago

  • Status changed from Need more information to Ready For Testing
  • Target version set to 1.15.0
  • Assignee changed from Anonymous to Dominic Cleal

If anybody is able to test this patch and provide feedback, it'd be much appreciated. It adds a single file into the Foreman install, then restart Foreman/httpd and see if you can reproduce the issue.

https://github.com/theforeman/foreman/pull/1007

Actions #20

Updated by Xavier ROUX over 10 years ago

I tested this patch and it solves my problem.
Thanks you.

Actions #21

Updated by Anne Hopkins over 10 years ago

Resolved issue for me as well. Thanks Dominic!

Actions #22

Updated by Dominic Cleal over 10 years ago

  • Has duplicate Bug #3612: Editing host after an compute associate ends in an oops added
Actions #23

Updated by Dominic Cleal over 10 years ago

  • Target version changed from 1.15.0 to 1.10.0
Actions #24

Updated by Dominic Cleal over 10 years ago

  • translation missing: en.field_release set to 3
Actions #25

Updated by Dominic Cleal over 10 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100
Actions #26

Updated by Dominic Cleal over 9 years ago

  • Related to Bug #8619: undefined method `stringify_keys' for #<RbVmomi::VIM ..> added
Actions #27

Updated by Dominic Cleal almost 9 years ago

  • Related to Bug #10336: foreman-rake prints "Workaround for RbVmomi may not work as ComputeResource is already loaded: #{ComputeResource}" added
Actions

Also available in: Atom PDF