Project

General

Profile

Bug #2808

nokogiri 1.6.0 incompatible with Ruby 1.8

Added by Dominic Cleal over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Urgent
Assignee:
Category:
-
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

fog 1.14.0 has been released, which relaxes the nokogiri requirement, allowing it to install a version that's no longer compatible with Ruby 1.8:

Installing nokogiri (1.6.0) 
Gem::InstallError: nokogiri requires Ruby version >= 1.9.2.

https://github.com/fog/fog#ruby-187

We should pin nokogiri, but only for Ruby 1.8. This is breaking test_develop.


Related issues

Related to Foreman - Tracker #4656: Drop Ruby 1.8 supportClosed

Associated revisions

Revision 0b547e84 (diff)
Added by Dominic Cleal over 6 years ago

fixes #2808 - pin nokogiri to 1.5.x for Ruby 1.8

Revision 8ecf4d4f (diff)
Added by Dominic Cleal over 6 years ago

fixes #2808 - pin nokogiri to 1.5.x for Ruby 1.8
(cherry picked from commit 0b547e84f7342cbb809ffe5e1f171c0f4b1e8f05)

History

#1 Updated by Dominic Cleal over 6 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Dominic Cleal

#2 Updated by Dominic Cleal over 6 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#3 Updated by Dominic Cleal almost 6 years ago

Also available in: Atom PDF