Project

General

Profile

Bug #28081

Unable to sync debian repos older than jessie

Added by Tomas Åberg over 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Repositories
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Hello!
Truly sorry if this is not the place for this bug report. I spent time searching for the right place and this is where I eventually ended up.

So, the problem is with the pulp_deb. Unfortunately our company have some old servers left and I need to synchronize the Debian wheezy repository.
When I try to sync the repository I get the following error:

 IOError: [Errno 2] No such file or directory: u'/var/cache/pulp/reserved_resource_worker-1@c332pc-katello/ca55db26-f364-40bc-bbac-b450445c56c0/dists/wheezy/contrib/binary-amd64/Packages.bz2

The reason for this error turns out to be that the wheezy archive repository doesn't use .bz2 extention, but instead .bz for Packages archive. Pulp looks for Packages.bz2 and not Packages.bz.
I have attached the journalctl log when this happens.

A potential fix could perhaps be some kind of regex that first tried to download .bz2 and if that fails, it tries the .bz extention.

journalctl-output.txt journalctl-output.txt 7.44 KB Log Tomas Åberg, 10/17/2019 09:09 AM

History

#1 Updated by James Jeffers over 2 years ago

  • Triaged changed from No to Yes
  • Status changed from New to Closed

This look like a pulp bug, and the issue tracker for that project can be found at https://pulp.plan.io/.

#2 Updated by Jonathon Turel about 2 years ago

  • Target version set to Katello Recycle Bin

Also available in: Atom PDF