Project

General

Profile

Bug #28493

Unable to sort tasks by duration

Added by Avi Sharvit about 2 years ago. Updated about 2 years ago.

Status:
Duplicate
Priority:
High
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Tested on
- snap 4 (tfm-rubygem-foreman-tasks-0.17.3-1.el7sat.noarch)
- snap 5 (tfm-rubygem-foreman-tasks-0.17.4-1.el7sat.noarch)
- Firefox 70.0.1 (64-bit), Chrome 78.0.3904.108 (Official Build) (64-bit)

While on snap 4 most of it works nicely, on snap 5 I get "Could not receive data: Request failed with status code 500" error when trying to sort the duration column (please see the attachment).

Traceback from the production.log follows:
2019-12-11T08:36:46 [I|app|d5172361] Started GET "/foreman_tasks/tasks?sort_by=duration&sort_order=ASC" for 10.34.131.204 at 2019-12-11 08:36:46 -0500
2019-12-11T08:36:46 [I|app|d5172361] Processing by ForemanTasks::ReactController#index as HTML
2019-12-11T08:36:46 [I|app|d5172361] Parameters: {"sort_by"=>"duration", "sort_order"=>"ASC"}
2019-12-11T08:36:46 [I|app|d5172361] Rendering /opt/theforeman/tfm/root/usr/share/gems/gems/foreman-tasks-0.17.4/app/views/foreman_tasks/layouts/react.html.erb
2019-12-11T08:36:46 [I|app|d5172361] Rendering layouts/base.html.erb
2019-12-11T08:36:46 [I|app|d5172361] Rendered /opt/theforeman/tfm/root/usr/share/gems/gems/foreman_theme_satellite-5.0.1.5/app/views/foreman_theme_satellite/_theme_client_side_branding.js.erb (0.5ms)
2019-12-11T08:36:46 [I|app|d5172361] Rendered layouts/base.html.erb (24.9ms)
2019-12-11T08:36:46 [I|app|d5172361] Rendered /opt/theforeman/tfm/root/usr/share/gems/gems/foreman-tasks-0.17.4/app/views/foreman_tasks/layouts/react.html.erb (26.7ms)
2019-12-11T08:36:46 [I|app|d5172361] Completed 200 OK in 36ms (Views: 26.4ms | ActiveRecord: 2.6ms)
2019-12-11T08:36:48 [I|app|d5166fe0] Started GET "/notification_recipients" for 10.34.131.204 at 2019-12-11 08:36:48 -0500
2019-12-11T08:36:48 [I|app|f7a1ea21] Started GET "/foreman_tasks/tasks/summary/24" for 10.34.131.204 at 2019-12-11 08:36:48 -0500
2019-12-11T08:36:48 [I|app|f977bc42] Started GET "/foreman_tasks/api/tasks?sort_by=duration&sort_order=ASC&include_permissions=true" for 10.34.131.204 at 2019-12-11 08:36:48 -0500
2019-12-11T08:36:48 [I|app|d5166fe0] Processing by NotificationRecipientsController#index as JSON
2019-12-11T08:36:48 [I|app|f7a1ea21] Processing by ForemanTasks::TasksController#summary as JSON
2019-12-11T08:36:48 [I|app|f7a1ea21] Parameters: {"recent_timeframe"=>"24"}
2019-12-11T08:36:48 [I|app|f977bc42] Processing by ForemanTasks::Api::TasksController#index as JSON
2019-12-11T08:36:48 [I|app|f977bc42] Parameters: {"sort_by"=>"duration", "sort_order"=>"ASC", "include_permissions"=>"true"}
2019-12-11T08:36:48 [I|app|d5166fe0] Completed 200 OK in 8ms (Views: 0.1ms | ActiveRecord: 1.3ms)
2019-12-11T08:36:48 [W|app|f977bc42] Action failed
2019-12-11T08:36:48 [I|app|f977bc42] Rendering api/v2/errors/standard_error.json.rabl within api/v2/layouts/error_layout
2019-12-11T08:36:48 [I|app|f977bc42] Rendered api/v2/errors/standard_error.json.rabl within api/v2/layouts/error_layout (0.5ms)
2019-12-11T08:36:48 [I|app|f977bc42] Completed 500 Internal Server Error in 11ms (Views: 1.1ms | ActiveRecord: 2.6ms)
2019-12-11T08:36:48 [I|app|f7a1ea21] Completed 200 OK in 15ms (Views: 0.4ms | ActiveRecord: 4.4ms)

Reproducer available at https://dhcp-3-5.vms.sat.rdu2.redhat.com

duration_sort (1).png View duration_sort (1).png 142 KB Avi Sharvit, 12/12/2019 11:53 AM
Duration sort%20(1)

Related issues

Is duplicate of foreman-tasks - Bug #28485: Cannot sort tasks by durationClosed

History

#1 Updated by Maria Agaphontzev about 2 years ago

  • Is duplicate of Bug #28485: Cannot sort tasks by duration added

#2 Updated by Maria Agaphontzev about 2 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF