Project

General

Profile

Bug #28768

exporting/importing report template process is causing a different report during the visualization (blank lines)

Added by Marek Hulán 7 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Reporting
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1778396

Description of problem:
When exporting the report template, the header is added automatically on the code. Once we just copy/paste the code back, we can see some new lines (according to the example below)

Version-Release number of selected component (if applicable):
6.6.z

How reproducible:
100%

Steps to Reproduce:
1. Create the report with the content below (please add the input field 'host' as well to avoid issues.
---
<% load_hosts(search: input('host')).each_record do |host| >
<

report_row(
'Server FQND': host.name
)
>
<
end >
<%= report_render %>
--

2. Clicking in preview we can see
---
Server FQND
contenthost1.usersys.redhat.com
contenthost2.usersys.redhat.com
---
3. Now let's save and export via webUI (report template page, then select the dropdown menu list side to Generate button - Export) and the code saved will be as below
---
< load_hosts(search: input('host')).each_record do |host| >
<
#
name: Hosts - complete list
snippet: false
template_inputs:
name: host
required: false
input_type: user
advanced: false
model: ReportTemplate
>
<

report_row(
'Server FQND': host.name
)
>
<
end -%>
<%= report_render %>
--

Actual results:
---

Server FQND
contenthost1.usersys.redhat.com
contenthost2.usersys.redhat.com
---

Expected results:
---
Server FQND
contenthost1.usersys.redhat.com
contenthost2.usersys.redhat.com
---

No new lines on the top. This is caused because of the last line of the header. If we change according to below, new lines will disappear
From
---
<%#
name: Hosts - complete list
snippet: false
template_inputs:
- name: host
required: false
input_type: user
advanced: false
model: ReportTemplate
%>
---

To
---
<%#
name: Hosts - complete list
snippet: false
template_inputs:
- name: host
required: false
input_type: user
advanced: false
model: ReportTemplate
%>
--

Additional info:

Associated revisions

Revision 95413a60 (diff)
Added by Marek Hulán 7 months ago

Fixes #28768 - always export metadata first

The old behavior was needed for templates that required to be the first thing in rendered result. Turns our metadata specified
before don't cause problems as long as they are correctly closed by -%>.
Community templates are updated in separate PR.

Revision 7c2ee7a4 (diff)
Added by Marek Hulán 7 months ago

Refs #28768 - update templates to start with metadata

History

#1 Updated by The Foreman Bot 7 months ago

  • Assignee set to Marek Hulán
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/7363 added

#2 Updated by The Foreman Bot 7 months ago

  • Pull request https://github.com/theforeman/community-templates/pull/678 added

#3 Updated by The Foreman Bot 7 months ago

  • Fixed in Releases 2.0.0 added

#4 Updated by Marek Hulán 7 months ago

  • Status changed from Ready For Testing to Closed

#5 Updated by Tomer Brisker 5 months ago

  • Category changed from Statistics to Reporting

Also available in: Atom PDF