Project

General

Profile

Bug #29672

Unable to update all packages for RHEL 8 clients via katello-agent

Added by Hao Yu about 2 years ago. Updated almost 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Tooling
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from bugzilla 1829866:

Getting the following error when trying to upgrade all packages(dnf upgrade) for a RHEL 8 client using katello-agent:

2020-04-30T13:20:14Z DDEBUG timer: sack setup: 2314 ms
2020-04-30T13:20:14Z DEBUG Completion plugin: Generating completion cache...
2020-04-30T13:20:14Z DEBUG Completion plugin: Generating completion cache...
2020-04-30T13:20:14Z DDEBUG Getting group metadata
2020-04-30T13:20:14Z DDEBUG Adding group file from repository: rhel-8-for-x86_64-appstream-rpms
2020-04-30T13:20:14Z DDEBUG Adding group file from repository: rhel-8-for-x86_64-baseos-rpms
2020-04-30T13:20:15Z DDEBUG Adding group file from repository: satellite-tools-6.6-for-rhel-8-x86_64-rpms
2020-04-30T13:20:15Z DDEBUG timer: loading comps: 72 ms
2020-04-30T13:20:15Z DEBUG Completion plugin: Generating completion cache...
2020-04-30T13:20:15Z CRITICAL Traceback (most recent call last):
File "/usr/lib/python3.6/site-packages/dnf/plugin.py", line 104, in _caller
getattr(plugin, method)()
File "/usr/lib/python3.6/site-packages/dnf-plugins/product-id.py", line 59, in transaction
if len(self.base.transaction) == 0:
TypeError: object of type 'NoneType' has no len()

Seems like there is no transaction ran when calling update without patterns:

In "/usr/lib/python3.6/site-packages/katello/agent/pulp/libdnf.py"

def update(self, patterns=(), advisories=()):
<snip>
if patterns: <================ This condition is skipping the upgrade when no patterns are provided.
lib.upgrade(patterns)
if self.commit:
lib.do_transaction()

I think it is the regression of the following fix:

https://bugzilla.redhat.com/show_bug.cgi?id=1713417
https://github.com/Katello/katello-host-tools/pull/98

Steps to Reproduce:
1. Go to Web UI -> Hosts -> Content Hosts -> choose a RHEL 8 client -> Packages -> Applicable -> Click "Update All Packages"
2. ssh to the RHEL 8 client, run "tail -f /var/log/dnf.log" to observe the error.

Actual results:
No packages are updated

Expected results:
All packages are updated

History

#1 Updated by Samir Jha about 2 years ago

  • Triaged changed from No to Yes
  • Target version set to Katello 3.16.0

#2 Updated by Jonathon Turel almost 2 years ago

  • Target version changed from Katello 3.16.0 to Katello Recycle Bin
  • Status changed from New to Duplicate

Closing as its a duplicate of https://projects.theforeman.org/issues/28909

Also available in: Atom PDF