Project

General

Profile

Bug #30035

Enabling Realm proxy on Foreman host requires manual gem installation

Added by Stephen Panicho over 2 years ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

I'm running Foreman 2.0 with Katello 1.15. I was attempting to install the Realm proxy on the same Foreman host.

Following the steps at https://theforeman.org/manuals/2.0/index.html#4.3.8Realm will cause the following error:

"Disabling all modules in the group ['realm_freeipa', 'realm'] due to a failure in one of them: Gem loading error: cannot load such file -- xmlrpc" 

I traced this to the following file:

/usr/share/foreman-proxy/bundler.d

group :realm_freeipa do
  gem 'xmlrpc', '~> 0.2' if RUBY_VERSION >= '2.4'
end

In order to solve this, I had to run the following:

scl enable tfm "gem install xmlrpc -v 0.2.1" 

Note that foreman-installer will not do this for you. After a reboot, the Realm proxy works as intended.


Related issues

Is duplicate of Packaging - Bug #30040: Foreman proxy realm plugin missing xmlrpc -- needs to install rh-ruby25-rubygem-xmlrpcClosed

History

#1 Updated by Ondřej Ezr over 1 year ago

  • Is duplicate of Bug #30040: Foreman proxy realm plugin missing xmlrpc -- needs to install rh-ruby25-rubygem-xmlrpc added

#2 Updated by Ondřej Ezr over 1 year ago

  • Status changed from New to Duplicate

This has been fixed in #30040 and released in 2.0.2.

Also available in: Atom PDF