Project

General

Profile

Bug #30963

pulpcore 3.7 upgrades fail due to python3-dynaconf-3.0.0-0.1.rc1

Added by Michael DePaulo 12 months ago. Updated 12 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
RPMs
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

The pulpcore 3.4 repo contains python3-dynaconf-3.0.0-0.1.rc1 . Emphasis on rc1.

The pulpcore 3.7 repo contains a python3-pulpcore package that requires python3-dynaconf >= 3.0.0. (It also contains newer python3-dynaconf, 3.1.1-1).

If a user yum updates python-pulpcore and the content plugins, dynaconf will not be updates. This is the current behavior of pulp_installer when upgrading Pulp 3.

However, pip (and Pulp when it goes to use dynaconf) sees it as 3.0.0rc1, which is less than 3.0.0, and it fails to start or run pulpcore-manager commands.

pulpcore-manager throws:
```
Traceback (most recent call last):
File "/usr/bin/pulpcore-manager", line 6, in <module>
from pkg_resources import load_entry_point
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3095, in <module>
@_call_aside
File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3079, in call_aside
f(*args, **kwargs)
File "/usr/lib/python3.6/site-packages/pkg_resources/
_init__.py", line 3108, in initialize_master_working_set
working_set = WorkingSet._build_master()
File "/usr/lib/python3.6/site-packages/pkg_resources/
_init__.py", line 572, in build_master
return cls._build_from_requirements(requires)
File "/usr/lib/python3.6/site-packages/pkg_resources/
_init__.py", line 585, in build_from_requirements
dists = ws.resolve(reqs, Environment())
File "/usr/lib/python3.6/site-packages/pkg_resources/
_init__.py", line 774, in resolve
raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'dynaconf<4.0,>=3.0' distribution was not found and is required by pulpcore
```

More info:
```
[root@centos-7 /]# pip3 list | grep dynaconf
DEPRECATION: The default format will switch to columns in the future. You can use --format=(legacy|columns) (or define a format=(legacy|columns) in your pip.conf under the [list] section) to disable this warning.
dynaconf (3.0.0rc1)
[root@centos-7 /]# yum info python3-dynaconf
Loaded plugins: fastestmirror, ovl
Loading mirror speeds from cached hostfile * base: mirrors.mit.edu * centos-sclo-rh: mirrors.advancedhosters.com * centos-sclo-sclo: mirror.trouble-free.net * epel: fedora-epel.mirrors.tds.net * extras: mirrors.advancedhosters.com * updates: mirror.atlanticmetro.net
Installed Packages
Name : python3-dynaconf
Arch : noarch
Version : 3.0.0
Release : 0.1.rc1.el7
Size : 412 k
Repo : installed
From repo : pulpcore
Summary : The dynamic configurator for your Python Project
URL : https://github.com/rochacbruno/dynaconf
License : MIT
Description : The dynamic configurator for your Python Project

Available Packages
Name : python3-dynaconf
Arch : noarch
Version : 3.1.1
Release : 1.el7
Size : 423 k
Repo : pulpcore/x86_64
Summary : The dynamic configurator for your Python Project
URL : https://github.com/rochacbruno/dynaconf
License : MIT
Description : The dynamic configurator for your Python Project
```

History

#1 Updated by Michael DePaulo 12 months ago

FYI: pulp_installer now updates every package in the repo when it does updates/upgrades:
https://github.com/pulp/pulp_installer/pull/453

#2 Updated by Evgeni Golov 12 months ago

This should be fixed by https://github.com/theforeman/pulpcore-packaging/pull/43

But the installer should still update everything.

#3 Updated by Ewoud Kohl van Wijngaarden 12 months ago

  • Status changed from New to Closed

Currently the pulpcore-packaging repository is not covered by Redmine. The question is: should it?

Also available in: Atom PDF