Project

General

Profile

Bug #3106

Consistent sorting of parameters in hosts and hostgroups

Added by Benjamin Papillon about 9 years ago. Updated about 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Web Interface
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Here we have around 50 parameters for hostgroup and around 100 hostgroups.

Parameters on each host or hostgroup are not saved in the same order they are entered.

It is desired to have a consistent sorting of parameters for host or hostgroups.

Steps to reproduce :
1. Assign many variables on host, ex:
key value
a 1
b 2
c 3
d 4
e 5
f 6
2. Save host
3. Edit the host
4. View parameters in disorder.


Related issues

Is duplicate of Foreman - Feature #2181: Ordering of ENC ParametersDuplicate2013-02-04

Associated revisions

Revision 189f9f34 (diff)
Added by Luke Alford about 9 years ago

fixes #3106 - consistent sorting of common parameters by name

Revision 088c53d6 (diff)
Added by Luke Alford about 9 years ago

fixes #3106 - consistent sorting of common parameters by name

(cherry picked from commit 189f9f34fe20aea60e86417c90b99dcea64f3e37)

History

#1 Updated by Dominic Cleal about 9 years ago

  • Tracker changed from Feature to Bug
  • Target version set to 1.3.0

#2 Updated by Dominic Cleal about 9 years ago

  • Related to Tracker #3112: [TRACKER] Issues to be released in 1.3 RC or final added

#3 Updated by Anonymous about 9 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

#4 Updated by Lukas Zapletal about 9 years ago

  • Related to deleted (Tracker #3112: [TRACKER] Issues to be released in 1.3 RC or final)

#5 Updated by Benjamin Papillon almost 9 years ago

  • Is duplicate of Feature #2181: Ordering of ENC Parameters added

Also available in: Atom PDF