Project

General

Profile

Bug #31763

satellite-clone restores postgresql.conf with root:root ownership causing failure to clone

Added by Mike McCune 9 months ago. Updated 9 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Tooling
Target version:
-
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

When cloning a 6.7 Satellite server, we perform the following steps:

1) install postgresql server packages:

https://github.com/RedHatSatellite/satellite-clone/blob/81e3be94c5f34887dfe133e9309946a1bd31c175/roles/satellite-clone/tasks/main.yml#L123

2) untar config files:

https://github.com/RedHatSatellite/satellite-clone/blob/81e3be94c5f34887dfe133e9309946a1bd31c175/roles/satellite-clone/tasks/main.yml#L194

3) remove postgresql.conf

https://github.com/RedHatSatellite/satellite-clone/blob/81e3be94c5f34887dfe133e9309946a1bd31c175/roles/satellite-clone/tasks/main.yml#L198

4) run satellite-installer:

https://github.com/RedHatSatellite/satellite-clone/blob/81e3be94c5f34887dfe133e9309946a1bd31c175/roles/satellite-clone/tasks/main.yml#L235

The issue is that satellite-installer does not properly re-set file permissions on postgresql.conf to postgresql:postgresql upon execution of the Puppet code to configure this file, it ends up being root:root as it likely doesn't expect this file to be completely missing.

This causes postgreql server to fail to start and the clone to fail completely.

We need to investigate removing the step (3) above and see if we still need to continue removing this config file as test runs without this step complete properly.

History

#1 Updated by James Jeffers 9 months ago

  • Status changed from New to Closed

Closing as we will work off the BZ and work the issue in the proper trackers there.

#2 Updated by John Mitsch 9 months ago

It could be an installer fix, but I think we need a bit more investigation to figure out where the upstream changes should live (sat-clone, foreman-maintain, and/or installer) and file more specific bugs. We can work off the BZ for now and take it from there. @Mike let me know if you want to approach it differently or had something else in mind!

#3 Updated by James Jeffers 9 months ago

  • Triaged changed from No to Yes

Also available in: Atom PDF