Project

General

Profile

Actions

Refactor #32130

closed

Drop support of Facter 2 facts

Added by Marek Hulán over 3 years ago. Updated about 3 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Facts
Target version:
-
Difficulty:
Triaged:
No
Fixed in Releases:
Found in Releases:

Description

Today we still support so called legacy facts in places we parse puppet facts. The drop of the Facter 2 was announced a while ago at https://community.theforeman.org/t/the-road-to-making-puppet-optional/17983 and Foreman 2.6/3.0 would be a good time to clean up this code


Related issues 1 (0 open1 closed)

Related to Foreman - Refactor #27906: Use modern Facter 3 factsClosedEwoud Kohl van WijngaardenActions
Actions #1

Updated by Ewoud Kohl van Wijngaarden over 3 years ago

I don't understand the goal of this issue. Why is it in the installer? It looks like it should be reported against core and then it's a duplicate of #27906.

Actions #2

Updated by Ewoud Kohl van Wijngaarden over 3 years ago

Actions #3

Updated by Marek Hulán over 3 years ago

  • Project changed from Installer to Foreman

My appologies, I used the wrong project. Which explains why searching for an existing ticket didn't show me anything. However, the linked issue seems to be marked as resolved already. We still have fallbacks to

operatingsystem
memorysize_mb
boardproductname

and probably others. This refactoring asks for the clean up of all of these to make to code base cleaner. Moving it to the Foreman project where it should have been opened.

Actions #4

Updated by Ewoud Kohl van Wijngaarden about 3 years ago

  • Category set to Facts

No, the other issue is Ready for testing but really should be new. I only prepared with a refactor to make it easier in the future. I've set that one back to New. Shall we close this as a duplicate?

Actions #5

Updated by Marek Hulán about 3 years ago

  • Status changed from New to Duplicate

I guess the other issue should have been a tracker if it was supposed to be implemented in multiple PRs. I don't mind closing this as duplicate, I'll copy the description from here to there.

Actions

Also available in: Atom PDF