Project

General

Profile

Bug #32312

Report Templates Host - Applied Errata report is empty.

Added by Waldirio Pinheiro over 1 year ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Category:
Hosts
Target version:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Description of problem:

Report Templates Host - Applied Errata report showing no data.

While generating Report Templates "Host - Applied Errata report" file is empty.

~~~~~~~
Login to Satellite WEB UI > Monitor > Report Templates > Host - Applied Errata
~~~~~~

Version-Release number of selected component (if applicable):
6.8

How reproducible:
100%

Steps to Reproduce:
1. // Generate Report:

~~~~~~~
Login to Satellite WEB UI > Monitor > Report Templates > Generate report for "Host - Applied Errata"

2. Generated report is empty.

3. Checked task "Actions::Katello::Host::Erratum::Install" for generated for applied errata on Satellite server but this task is also empty.

~~~~~~~
[root@satellite ]# hammer task list --search="label = Actions::Katello::Host::Erratum::Install"
---|--------|-------|--------|------------|----------|-------|------------
ID | ACTION | STATE | RESULT | STARTED AT | ENDED AT | OWNER | TASK ERRORS
---|--------|-------|--------|------------|----------|-------|------------
~~~~~~~
~

4. Noticed task "Actions::Katello::Host::Erratum::ApplicableErrataInstall" is generated for applied errata.

~~~~~~~
[root@satellite ~]# hammer task list --search="label = Actions::Katello::Host::Erratum::ApplicableErrataInstall"
-------------------------------------|-----------------------------------------------------------|---------|---------|---------------------|---------------------|---------|---------------------------------------------------------------------------------
ID | ACTION | STATE | RESULT | STARTED AT | ENDED AT | OWNER | TASK ERRORS
-------------------------------------|-----------------------------------------------------------|---------|---------|---------------------|---------------------|---------|---------------------------------------------------------------------------------
1111xaxa-8e70-xaxa-8bd9-23f091xxxxxx | Install Applicable Errata on Host1-example.com | stopped | success | 2021/03/20 10:47:15 | 2021/03/20 10:51:15 | admin |

3333xaxa-9945-2d5a-xaxa-1c8693xxxxxx | Install Applicable Errata on Host2-example.com | stopped | success | 2021/03/20 07:51:20 | 2021/03/20 07:56:20 | admin |

5555xbxb-dxxb-5e9a-xbxb-dz50b7xxxxxx | Install Applicable Errata on Host3-example.com | stopped | success | 2021/03/20 07:51:06 | 2021/03/20 07:50:06 | admin |
-------------------------------------|-----------------------------------------------------------|---------|---------|---------------------|---------------------|---------|---------------------------------------------------------------------------------
[root@satellite ]#
~~~~~~~
~

5. Report is only consider task label "Actions::Katello::Host::Erratum::Install" where as report do not consider the task label "Actions::Katello::Host::Erratum::ApplicableErrataInstall"

~~~~~~
https://github.com/Katello/katello/blob/53e9d86ba155a175fb2efeec00e84c20702b6ca4/app/lib/katello/concerns/base_template_scope_extensions.rb#L110
~~~~~~

Actual results:

It does not contain any errata information in the Applied Errata report.

Expected results:
Host - Applied Errata report should contain the errata information.

Associated revisions

Revision cc397e2f (diff)
Added by Waldirio Pinheiro over 1 year ago

Fixes #32312 - Typo on the test. Instead of `stopped` it was `stoppped`

Revision f53ee79f (diff)
Added by Hao Yu over 1 year ago

Fixes #32312 - Applied errata not showing in the report.

History

#1 Updated by Waldirio Pinheiro over 1 year ago

  • Pull request https://github.com/Katello/katello/pull/9282 added

#2 Updated by The Foreman Bot over 1 year ago

  • Status changed from New to Ready For Testing

#3 Updated by The Foreman Bot over 1 year ago

  • Fixed in Releases Katello 4.2.0 added

#4 Updated by Waldirio Pinheiro over 1 year ago

  • Status changed from Ready For Testing to Closed

#5 Updated by Chris Roberts over 1 year ago

  • Target version set to Katello 4.1.0
  • Assignee set to Waldirio Pinheiro
  • Category set to Hosts

#6 Updated by Chris Roberts over 1 year ago

  • Triaged changed from No to Yes

#7 Updated by The Foreman Bot over 1 year ago

  • Pull request https://github.com/Katello/katello/pull/9309 added

#8 Updated by Marek Hulán over 1 year ago

  • Status changed from Closed to Ready For Testing

reopening since a second PR was opened

#9 Updated by Hao Yu over 1 year ago

  • Status changed from Ready For Testing to Closed

#10 Updated by The Foreman Bot 7 months ago

  • Pull request https://github.com/Katello/katello/pull/10108 added

Also available in: Atom PDF