Project

General

Profile

Bug #33039

[BUG] The --docker-tags-whitelist option is not allowing the syncing of whitelisted tags for a docker type repo in Satellite 6

Added by Justin Sherrill 10 months ago. Updated 9 months ago.

Status:
Rejected
Priority:
Normal
Category:
Repositories
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1947628

Description of problem:

hammer is not handing the "." in repository tags properly when using --docker-tags-whitelist option. I could reproduce this issue with any repos from rhosp-rhel8/* .

Version-Release number of selected component (if applicable):
Satellite 6.8.5
Satellite 6.7.5

How reproducible:
Always

Steps to Reproduce:

1. hammer product create --name container --organization RedHat

2. hammer repository create --name "rhosp-rhel8/openstack-aodh-base" --upstream-username USER --upstream-password "PASSWORD" --docker-upstream-name "rhosp-rhel8/openstack-aodh-base" --product container --url "https://registry.redhat.io" --publish-via-http yes --content-type docker --organization RedHat

3. hammer repository update --name "rhosp-rhel8/openstack-aodh-base" --product container --docker-tags-whitelist "16.1" --organization RedHat

4. hammer repository synchronize --name "rhosp-rhel8/openstack-aodh-base" --product "container" --organization RedHat

5. hammer repository update --name "rhosp-rhel8/openstack-aodh-base" --product container --docker-tags-whitelist "16\.1" --organization RedHat

6. hammer repository synchronize --name "rhosp-rhel8/openstack-aodh-base" --product "container" --organization RedHat

Actual results:

At step 3, the tag will be correctly set to 16.1 but at step 4 , repo sync will not download any data.
~~
  1. hammer repository synchronize --name "rhosp-rhel8/openstack-aodh-base" --product "container" --organization RedHat
    [...............................................................................................................................................................................] [100%]
    ~~
At step 5, when I escape the "." with "\." and update the tag as "16\.1" , it will set the tag as 16.1 only and at step 6, it will download the blobs.
~~
  1. hammer repository synchronize --name "rhosp-rhel8/openstack-aodh-base" --product "container" --organization RedHat
    [...............................................................................................................................................................................] [100%]
    New blobs: 12.
    ~~

Expected results:

--docker-tags-whitelist "16.1" should work and sync after that should allow downloading the data as well for that tag.

Additional info:

  • This issue cannot be reproduced if we set the "Limit Sync Tags" from Satellite UI as 16.1. So from UI it works just fine.

History

#1 Updated by The Foreman Bot 10 months ago

  • Assignee set to Justin Sherrill
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/9472 added

#2 Updated by James Jeffers 10 months ago

  • Triaged changed from No to Yes
  • Target version set to Katello 4.2.0

#3 Updated by Justin Sherrill 10 months ago

  • Status changed from Ready For Testing to Rejected

can't reproduce this with pulp 3.14 and katello 4.1

#4 Updated by Justin Sherrill 9 months ago

  • Target version changed from Katello 4.2.0 to Katello Recycle Bin

Also available in: Atom PDF