Project

General

Profile

Bug #34464

Misleading error message when incorrect org label is entered

Added by Lucy Fu 5 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Inter Server Sync
Target version:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=2050323

Description of problem:
Misleading error message is displayed when wrong organization label is entered into 'Organization Label' field in 'CDN Configuration' tab of 'Content->Subscriptions->Manage Manifest'

Version-Release number of selected component (if applicable):
-

How reproducible:
always

Steps to Reproduce:
  1. source
    1. Prepare content on source Satellite server
  2. target
    1. Prepare Content Credential or use existing (wget http://<source_server>/pub/katello-server-ca.crt; hammer content-credentials create --name "SourceCA" --organization-title "Default Organization" --path katello-server-ca.crt --content-type "cert")
    3. Go to 'Content->Subscriptions->Manage Manifest->CDN Configuration'
    4. Enter valid values, except Organization Label (use invalid, e.g. "Bad_Org") and press "Update"

Actual results:
Internal Server Error: the server was unable to finish the request. This may be caused by unavailability of some required service, incorrect API call or a server-side bug. There may be more information in the server's logs.

Expected results:
Some reasonable error message is displayed (e.g. "Organization label not found")

Additional info:

Associated revisions

Revision cf5f9c87 (diff)
Added by vagrant 4 months ago

Fixes #34464 - Check organization's existence for CDN configuration

History

#1 Updated by The Foreman Bot 5 months ago

  • Assignee set to Lucy Fu
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/9956 added

#2 Updated by The Foreman Bot 4 months ago

  • Fixed in Releases Katello 4.5.0 added

#3 Updated by Anonymous 4 months ago

  • Status changed from Ready For Testing to Closed

#4 Updated by Chris Roberts 4 months ago

  • Triaged changed from No to Yes
  • Target version changed from Katello 4.4.0 to Katello 4.5.0
  • Subject changed from Misleading error message when incorrect org label is entered to Misleading error message when incorrect org label is entered

#5 Updated by The Foreman Bot 4 months ago

  • Pull request https://github.com/Katello/katello/pull/9899 added

Also available in: Atom PDF