Project

General

Profile

Bug #34760

Hide profiles for module streams since we no longer have that info indexed from pulp

Added by Samir Jha 8 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Content Views
Target version:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Description of problem:

No profiles are shown for any module streams

Version-Release number of selected component (if applicable):
RHEL 6.10.2

How reproducible:
every time

Steps to Reproduce:
1. Sync RHEL8 Appstream repo
2. - WebUI --> Content --> Module Streams --> $stream --> Profiles tab --> 'No profiles to show'

Actual results:

  1. for id in $(hammer --username admin --password xxxx --no-headers module-stream list | awk {'print $1'}); do hammer --username admin --password xxxxx module-stream info --id $id | grep Profiles -A 1; done
    ~~~
    Profiles:

Profiles:

Profiles:

Profiles:

Expected results:

  1. for id in $(hammer --username admin --password xxxx --no-headers module-stream list | awk {'print $1'}); do hammer --username admin --password xxxx module-stream info --id $id | grep Profiles -A 1; done
    ~~~
    Profiles:
    1) ID: 28
    Profiles:
    1) ID: 266
    Profiles:
    1) ID: 256
    Profiles:
    1) ID: 23

Additional info:
Copied from: https://bugzilla.redhat.com/show_bug.cgi?id=2050100#c8

Associated revisions

Revision 3afbe21c (diff)
Added by Samir Jha 8 months ago

Fixes #34760 - Hide profiles for module streams (#10060)

History

#1 Updated by The Foreman Bot 8 months ago

  • Assignee set to Samir Jha
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/10060 added

#2 Updated by Jeremy Lenz 8 months ago

  • Triaged changed from No to Yes
  • Target version set to Katello 4.4.1
  • Subject changed from Hide profiles for module streams since we no longer have that info indexed from pulp to Hide profiles for module streams since we no longer have that info indexed from pulp

#3 Updated by The Foreman Bot 8 months ago

  • Fixed in Releases Katello 4.5.0 added

#4 Updated by Samir Jha 8 months ago

  • Status changed from Ready For Testing to Closed

#5 Updated by The Foreman Bot 7 months ago

  • Pull request https://github.com/Katello/katello/pull/10073 added

Also available in: Atom PDF