Project

General

Profile

Actions

Bug #36739

closed

Product without any repo is added to a Sync Plan regardless the error message

Added by Samir Jha 10 months ago. Updated 9 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Sync Plans
Target version:
Difficulty:
Triaged:
Yes
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=2236502

Description of problem:
Since 6.14 an error message is shown when you try to add a Product with no repos to a Sync Plan, but the product is added regardless the message.

Version-Release number of selected component (if applicable):
6.14.0 snap 14

How reproducible:
always

Steps to Reproduce:
1. Create a custom Product without any repo.
2. Create a Sync Plan.
3. Add the Product to the Sync Plan.

Actual results:
Error message "Cannot add product <prod> because it is disabled." is shown, but the product is added anyway.

Expected results:
Product is not added.

Actions #1

Updated by The Foreman Bot 10 months ago

  • Status changed from New to Ready For Testing
  • Assignee set to Samir Jha
  • Pull request https://github.com/Katello/katello/pull/10731 added
Actions #2

Updated by Ian Ballou 9 months ago

  • Subject changed from Product without any repo is added to a Sync Plan regardless the error message to Product without any repo is added to a Sync Plan regardless the error message
  • Target version set to Katello 4.11.0
  • Triaged changed from No to Yes
Actions #3

Updated by The Foreman Bot 9 months ago

  • Fixed in Releases Katello 4.11.0 added
Actions #4

Updated by Samir Jha 9 months ago

  • Status changed from Ready For Testing to Closed
Actions

Also available in: Atom PDF