Project

General

Profile

Bug #37

Failed to process report due to undefined method

Added by Carl Caum about 10 years ago. Updated about 10 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Puppet Reports
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Everytime I get a report using the foreman reports tool on the puppetmaster, it fails to process the report. Specifically, I get this error for every host report recieved:

failed to process report for lvxentest01.lightningsource.com due to:undefined method `[]' for #<Puppet::Util::Metric:0x2aaaabdbea18>

Attached is the report.

200910061531.yaml 200910061531.yaml 1.44 KB Carl Caum, 10/06/2009 04:45 PM

History

#1 Updated by Carl Caum about 10 years ago

Additional Info

Foreman Version: latest stable (0.1-1)
Ruby Version: 1.8.5
OS: CentOS 5.3

#2 Updated by Carl Caum about 10 years ago

I've narrowed down this issue to lines 55 and 56 in the app/models/report.rb file. However I don't see what the problem is. When these lines are removed, Foreman starts to successfully process MOST reports sent to it. However, I get different exceptions thrown when they are removed.

#3 Updated by Ohad Levy about 10 years ago

Carl Caum wrote:

I've narrowed down this issue to lines 55 and 56 in the app/models/report.rb file. However I don't see what the problem is. When these lines are removed, Foreman starts to successfully process MOST reports sent to it. However, I get different exceptions thrown when they are removed.

that is strange, I've imported your report and it went just fine.

which version of Puppet are you using?

#4 Updated by Carl Caum about 10 years ago

  • Status changed from New to Closed

Ugh, somehow that box was still running puppet version 0.24.5. I updated to 0.24.8 and everything's working fine.

Also available in: Atom PDF