Project

General

Profile

Bug #4252

Correctly handle when VM is migrated between datacenters

Added by Libor Zoubek about 9 years ago. Updated about 9 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Compute resources - oVirt
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Foreman is not able to handle VM migration between datacenters:

Steps to reproduce:
1. Have 2 oVirt datacenters (A,B), add both as compute resources.
2. create VM using foreman in A
3. migrate VM in oVirt to datacenter B (use export from A, delete the original VM in A, then import to B)

Actual results:

You can still see your VM in foreman, power it off and on, see spice console etc. But when attempt to edit the host you get "not found"
VM still refers to datacenter A. compute-resource B therefore cannot be removed from foreman

Expected results:

VM should refer to correct datacenter and should be editable.

I'd be happy for any kind of workaround so i could "refresh" such hosts.


Related issues

Is duplicate of Foreman - Feature #3909: compute resources prevent or disassciate host from VM prevent vm deletionClosed2013-12-18

History

#1 Updated by Dominic Cleal about 9 years ago

  • Is duplicate of Feature #3909: compute resources prevent or disassciate host from VM prevent vm deletion added

#2 Updated by Dominic Cleal about 9 years ago

  • Status changed from New to Duplicate

#3909 should provide the functionality you need to disassociate the VM from its old CR and reassociate with the current one.

Also available in: Atom PDF