Project

General

Profile

Bug #6087

input into audit goes wrong

Added by Jan van Lith over 5 years ago. Updated over 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Audit Log
Target version:
-
Difficulty:
trivial
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

When adding a value lager than 255 chars in a puppet class. The saving of the audit log in the database goes wrong. The data field is varchar and (255) big. Not large enough!

ActiveRecord::StatementInvalid
PGError: ERROR: value too long for type character varying(255) : INSERT INTO "audits" ("action", "associated_id", "associated_name", "associated_type", "auditable_id", "auditable_name", "auditable_type", "audited_changes", "comment", "created_at", "remote_address", "user_id", "user_type", "username", "version") VALUES ($1, $2, $3, $4, $5, $6, $7, $8, $9, $10, $11, $12, $13, $14, $15) RETURNING "id"
app/controllers/puppetclasses_controller.rb:32:in `update'
app/models/concerns/foreman/thread_session.rb:33:in `clear_thread'
lib/middleware/catch_json_parse_errors.rb:9:in `call'


Related issues

Is duplicate of Foreman - Bug #5671: Stack trace due to audit table field being too shortClosed2014-05-12

History

#1 Updated by Dominic Cleal over 5 years ago

  • Is duplicate of Bug #5671: Stack trace due to audit table field being too short added

#2 Updated by Dominic Cleal over 5 years ago

  • Status changed from New to Duplicate

Thanks for the report, we've fixed this under #5671 for Foreman 1.5.1.

Also available in: Atom PDF