Project

General

Profile

Actions

Bug #6110

closed

"Hosts -> New Host" generates an error

Added by Paul Calabro about 10 years ago. Updated about 10 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Difficulty:
Triaged:
Fixed in Releases:
Found in Releases:

Description

Stack trace below:

NoMethodError
undefined method `[]' for nil:NilClass
app/models/concerns/foreman/sti.rb:22:in `new'
app/models/concerns/foreman/sti.rb:22:in `new_with_cast'
app/models/host.rb:16:in `method_missing'
app/controllers/hosts_controller.rb:73:in `new'
app/models/concerns/foreman/thread_session.rb:33:in `clear_thread'
lib/middleware/catch_json_parse_errors.rb:9:in `call'
Actions #1

Updated by Paul Calabro about 10 years ago

This can be closed since the issue was actually caused by this plugin: https://github.com/theforeman/foreman_custom_parameters
Uninstalling that plugin resolved the issue.

Actions #2

Updated by Dominic Cleal about 10 years ago

  • Status changed from New to Rejected
Actions

Also available in: Atom PDF