Project

General

Profile

Actions

Bug #6130

closed

Saving a computer profile generates an error

Added by Paul Calabro about 10 years ago. Updated almost 10 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Difficulty:
Triaged:
Fixed in Releases:
Found in Releases:

Description

Steps to reproduce:

  1. Go to 'Infrastructure' -> 'Compute Profiles'
  2. Click 'New Compute Profile'
  3. Give the profile a name and click 'Submit'
  4. Go to 'Infrastructure' -> 'Compute Profiles'
  5. Click on a compute resource on the left
  6. Hit 'Save'

You should be presented with the following error:

NoMethodError
undefined method `vm_description' for #<Fog::Compute::XenServer::Server:0x007f3bf8d8c030>
app/models/compute_attribute.rb:26:in `pretty_vm_attrs'
app/models/compute_attribute.rb:32:in `update_name'
app/controllers/compute_attributes_controller.rb:10:in `create'
app/models/concerns/foreman/thread_session.rb:33:in `clear_thread'
lib/middleware/catch_json_parse_errors.rb:9:in `call'
Actions #1

Updated by Paul Calabro almost 10 years ago

This seems to be resolved. Possibly with one of the recent updates. This can be closed.

Actions #2

Updated by Dominic Cleal almost 10 years ago

  • Status changed from New to Resolved
Actions

Also available in: Atom PDF