Project

General

Profile

Bug #6160

False positive validation prevents saving network provisioned host with compute profile with image

Added by Ivan Necas almost 5 years ago. Updated 10 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Host creation
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

1. add image to libvirt resource
2. create a compute profile for libvirt, include the image (doesn't seem to be have nothing selected)
3. perform network based provisioning
4. the the provisioning calls foreman at the end, it fails on

"Selected image does not belong to localhost (Libvirt)"]}"

The problem with image not being find in the compute resource was caused by http://projects.theforeman.org/issues/6159

However, there is no reason to do this validation for build-based provisioning.

Associated revisions

Revision f7b85549 (diff)
Added by Ivan Necas almost 5 years ago

Fixes #6160 - don't validate images for network based provisioning

Revision 9ee691ab (diff)
Added by Ivan Necas almost 5 years ago

Fixes #6160 - don't validate images for network based provisioning

(cherry picked from commit f7b855491abbfd1737a2c7291ac4b16f8bc98017)

History

#1 Updated by Dominic Cleal almost 5 years ago

  • Status changed from Assigned to Ready For Testing
  • Target version set to 1.8.1
  • Legacy Backlogs Release (now unused) set to 18

#2 Updated by Ivan Necas almost 5 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#3 Updated by Bryan Kearney almost 5 years ago

  • Bugzilla link set to https://bugzilla.redhat.com/show_bug.cgi?id=1111593

Also available in: Atom PDF