Project

General

Profile

Bug #6281

Attempting to remove openstack compute resource gives FK error

Added by Justice London about 5 years ago. Updated about 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

I am attempting to remove an openstack compute resource which is no longer tied to any hosts and receive the following error:

PG::ForeignKeyViolation
ERROR: update or delete on table "images" violates foreign key constraint "hosts_image_id_fk" on table "hosts" DETAIL: Key (id)=(1) is still referenced from table "hosts".
app/controllers/compute_resources_controller.rb:72:in `destroy'
app/models/concerns/foreman/thread_session.rb:33:in `clear_thread'
lib/middleware/catch_json_parse_errors.rb:9:in `call'

If you need any further details let me know. I verified and no hosts are currently using this resource.


Related issues

Is duplicate of Foreman - Bug #4416: 500 FK error when deleting old image in compute resourceClosed2014-02-23

History

#1 Updated by Dominic Cleal about 5 years ago

  • Is duplicate of Bug #4416: 500 FK error when deleting old image in compute resource added

#2 Updated by Dominic Cleal about 5 years ago

  • Status changed from New to Duplicate

Thanks for the report, we're tracking this under #4416.

Also available in: Atom PDF