Project

General

Profile

Bug #6482

Engine Models are Duplicated in Permssions Resources

Added by Stephen Benjamin over 6 years ago. Updated over 6 years ago.

Status:
Rejected
Priority:
Normal
Category:
Users, Roles and Permissions
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

For Katello, the Permissions model ends up doubling the list of models, one with single quotes, one without. This ends up showing in the filter list twice -- with the humanized name, and without.

e.g.:

1.9.3-p448 :015 > Permission.uniq.order(:resource_type).pluck(:resource_type).compact
  SQL (2.1ms)  SELECT DISTINCT "permissions"."resource_type" FROM "permissions" ORDER BY resource_type
 => ["Architecture", "Audit", "AuthSourceLdap", "Bookmark", "CommonParameter", "ComputeProfile", "ComputeResource", "ConfigTemplate", "Domain", "Environment", "FactValue", "Filter", "Host", "HostClass", "Hostgroup", "Image", "'Katello::ActivationKey'", "Katello::ActivationKey", "'Katello::ContentView'", "Katello::ContentView", "'Katello::GpgKey'", "Katello::GpgKey", "'Katello::HostCollection'", "Katello::HostCollection", "'Katello::KTEnvironment'", "Katello::KTEnvironment", "'Katello::Product'", "Katello::Product", "'Katello::SyncPlan'", "Katello::SyncPlan", "'Katello::System'", "Katello::System", "Location", "LookupKey", "Medium", "Model", "Operatingsystem", "Organization", "'Organization'", "Parameter", "Ptable", "Puppetclass", "Realm", "Report", "Role", "SmartProxy", "'SmartProxy'", "Subnet", "Trend", "User", "Usergroup"]

Katello is only sending one set of permissions so I'm not sure how this is getting doubled.


Related issues

Related to Katello - Bug #6461: Invalid resource types show up in the permission filters screen Closed2014-07-01

History

#1 Updated by Stephen Benjamin over 6 years ago

PR https://github.com/theforeman/foreman/pull/1557

Maybe there's a better fix to solve the deeper problem.

#2 Updated by Eric Helms over 6 years ago

  • Related to Bug #6461: Invalid resource types show up in the permission filters screen added

#3 Updated by Dominic Cleal over 6 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Stephen Benjamin
  • Target version set to 1.8.1

#4 Updated by Dmitri Dolguikh over 6 years ago

  • Target version changed from 1.8.1 to 1.8.0

#5 Updated by Stephen Benjamin over 6 years ago

  • Status changed from Ready For Testing to Closed

Not a bug in Foreman, it's on Katello side.

http://projects.theforeman.org/issues/6461

#6 Updated by Dominic Cleal over 6 years ago

  • Status changed from Closed to Rejected
  • Target version deleted (1.8.0)

Also available in: Atom PDF