Project

General

Profile

Bug #718

Permission denied trying to write to tftp dir directly instead of using smart proxy

Added by Jeff Weiss over 8 years ago. Updated over 8 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
TFTP
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Processing HostsController#setBuild (for 10.11.228.39 at 2011-03-08 14:29:29) [GET]
Parameters: {"action"=>"setBuild", "id"=>"testhost1.jweiss.redhat.com", "controller"=>"hosts"}
TFTP Failed: Permission denied - /usr/share/foreman/tftp
Redirected to http://jweiss.usersys.redhat.com:5000/hosts/testhost1.jweiss.redhat.com
Completed in 13ms (DB: 4) | 302 Found [http://jweiss.usersys.redhat.com/hosts/testhost1.jweiss.redhat.com/setBuild]

"/usr/share/foreman/tftp" - It appears to be constructing this dir from foreman user's HOME dir (/usr/share/foreman), and the ":tftppath: tftp/" setting in
/etc/foreman/settings.yaml.

The problem is this dir is not writable by foreman, but really it should not even be attempting to write there. It should be using the smart proxy which has its own tftp dir setting and actually has permission to write to it. I talked with jsherrill about this and he was not able to reproduce it on his system. Neither of us could find any setting I had missed that would fix it.


Related issues

Has duplicate Foreman - Bug #702: remove pxe-config-link when changing the mac addressClosed2011-03-02

History

#1 Updated by Ohad Levy over 8 years ago

  • Category set to TFTP
  • Target version set to 0.2

You are correct, if you are using a smart proxy, the old legacy tftp code should not be executed.

#2 Updated by Ohad Levy over 8 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF