Project

General

Profile

Bug #7494

Search on usergroup page doesn't filter the specified string (w/wo quotes)

Added by Dominic Cleal about 6 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Search
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1142588
Description of problem:
Automation tests were failing as UI doesn't search usergroup names properly. Initially I thought problem is only with utf8 and latin1 characters, issue is with alpha nd numeric strings too.

Version-Release number of selected component (if applicable):
Sat6 GA Z release
Satellite-6.0.4-RHEL-6-20140915.0

How reproducible:
always

Steps to Reproduce:
1. create usergroup with alpha, numeric, latin and utf8 chars
2. user searchbar on usergroup page to search/filter any one created in step1
3.

Actual results:
Search won't filter the given string

Expected results:
Search should filter the only specified string

Additional info:
no error in logs

Associated revisions

Revision 35d6eb40 (diff)
Added by Shimon Shtein over 4 years ago

Fixes #7494 - added search parameter to index action of usergroups

Revision 13a3d8bd (diff)
Added by Shimon Shtein over 4 years ago

Fixes #7494 - added search parameter to index action of usergroups

(cherry picked from commit 35d6eb40a800b6f4ea04e53eb3bb9631504863db)

History

#1 Updated by Dominic Cleal about 6 years ago

  • Category set to Search

#2 Updated by Shimon Shtein over 4 years ago

  • Assignee set to Shimon Shtein

#3 Updated by The Foreman Bot over 4 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/3278 added

#4 Updated by Shimon Shtein over 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#5 Updated by Dominic Cleal over 4 years ago

  • Legacy Backlogs Release (now unused) set to 141

Also available in: Atom PDF