Project

General

Profile

Feature #79

reports page should have filter checkboxes

Added by Martin Englund over 9 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Usually you aren't interested in the reports with no changes, so there should be a checkbox on the /reports page (checked by default) which hides those reports


Related issues

Follows Foreman - Feature #248: Generalise the searchbar and tabs to support multiple controllersClosed2010-05-13

History

#1 Updated by Ohad Levy over 9 years ago

I would assume thats not too hard to add, nevertheless, I've created the dashboard with the hope is that it will show you what usually one would like to watch, leaving the detailed reports if required (under reports).

#2 Updated by Martin Englund over 9 years ago

I'll have a fix available soon - I just need to get foreman setup on my development server...

The easiest way is to use the conditions_for_collection controller method, e.g.

def conditions_for_collection
  ['status != 0']
end

#3 Updated by Ohad Levy over 9 years ago

  • Status changed from New to Feedback
  • Assignee changed from Ohad Levy to Martin Englund

will you implement this or should I?

are you aware that there is already a link with the same values through the dashboard?

#4 Updated by Martin Englund over 9 years ago

I have a prototype already, but it relies on modifying the reports table to remove the status column and add columns for failed, failed restarts, skipped and changed. Do you want me to include that or do you want to do that change?

#5 Updated by Martin Englund over 9 years ago

I just noticed refactor# 80 and which this partly depends on. I'll start with by just adding a check box to hide all "ok" reports.

#6 Updated by Martin Englund over 9 years ago

I'm looking at using:
http://github.com/tvongaza/active_scaffold_list_filters
to implement this.

#7 Updated by Ohad Levy over 9 years ago

Martin Englund wrote:

I'm looking at using:
http://github.com/tvongaza/active_scaffold_list_filters
to implement this.

thats interesting, might also fit to hosts filtering (e.g. environments, domains etc)

#8 Updated by Ohad Levy about 9 years ago

  • Category changed from Puppet Reports to Web Interface
  • Status changed from Feedback to New
  • Assignee changed from Martin Englund to Paul Kelly
  • Target version set to 0.1-5

might be duplicate of search bar, assigning to Paul just to be on the safe side.

#9 Updated by Ohad Levy almost 9 years ago

  • Status changed from New to Closed

implemented in ticket #249

Also available in: Atom PDF