Project

General

Profile

Feature #7910

Implement razor-like automated provisioning

Added by Lukas Zapletal almost 7 years ago. Updated almost 7 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

In Foreman, we can easily implement automated discovery by creating new model called DiscoveryRule with:

- name: name a the rule
- query: scoped_search expression
- host group: associated host group
- hostname: safemode expression to generate hostname (e.g. "node#{facts[:mac]}.example.com")
- max count: maximum allocation for this rule
- priority: integer giving rule priorities
- enabled: temporary disable a rule

For each discovered node, our plugin would execute query for each rule sorted by given priority. If a rule matches, host group is associated, host created and node rebooted for provisioning. Counter for each rule is increased and if it hits maximum count, query is no longer active. To speed up queries, we will add "and hostname = 'discovered_host_name'" to each query.

In the UI, we will need to create:

- rules CRUD
- re-apply automated provisioning button on the Discovered Hosts

Foreman core integration require to decrease counter when a host is deleted. For fluent user experience, we may want to add new button Delete and Reboot so users are able to return machines back to pool easily.


Related issues

Has duplicate Discovery - Feature #3860: Implement fully automated provisioningClosed2013-12-12

History

#1 Updated by Lukas Zapletal almost 7 years ago

  • Is duplicate of Feature #3860: Implement fully automated provisioning added

#2 Updated by Greg Sutcliffe almost 7 years ago

  • Is duplicate of deleted (Feature #3860: Implement fully automated provisioning)

#3 Updated by Greg Sutcliffe almost 7 years ago

  • Has duplicate Feature #3860: Implement fully automated provisioning added

#4 Updated by Greg Sutcliffe almost 7 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF