Project

General

Profile

Bug #8504

foreman-postgresql installation failed because SCL yum repo metadata not refreshed

Added by Kris Buytaert over 5 years ago. Updated over 2 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
foreman-installer script
Target version:
-
Difficulty:
easy
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Foreman installer failes because it can't install foreman-postgresql

SCL repo config is in place and after aborting the installer and running yum clean all it does proceed as expected.

This is most probably a dependency issue.

[root@localhost ~]# foreman-installer
/Stage[main]/Foreman::Install/Package[foreman-postgresql]/ensure: change from absent to present failed: Execution of '/usr/bin/yum -d 0 -e 0 -y install foreman-postgresql' returned 1:
Installing info: RESOURCE Apache::Mod[alias] [25%] [......... ]^C/usr/lib/ruby/gems/1.8/gems/kafo-0.6.5/lib/kafo/kafo_configure.rb:317:in `each': Interrupt
from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.5/lib/kafo/kafo_configure.rb:317:in `run_installation'
from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.5/lib/kafo/kafo_configure.rb:315:in `spawn'
from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.5/lib/kafo/kafo_configure.rb:315:in `run_installation'
from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.5/lib/kafo/kafo_configure.rb:109:in `execute'
from /usr/lib/ruby/gems/1.8/gems/clamp-0.6.2/lib/clamp/command.rb:68:in `run'
from /usr/lib/ruby/gems/1.8/gems/clamp-0.6.2/lib/clamp/command.rb:126:in `run'
from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.5/lib/kafo/kafo_configure.rb:116:in `run'
from /usr/sbin/foreman-installer:58

foreman-installer.1.log foreman-installer.1.log 313 KB Foreman installer log Kris Buytaert, 11/25/2014 08:15 AM

History

#1 Updated by Dominic Cleal over 5 years ago

My only guess as to the cause, is that some metadata already existed in /var/cache/yum for the "SCL" repository before it was added with centos-release-SCL. (Maybe it'd been configured already recently, or already existed with another baseurl?)

The module could perhaps run yum clean through a refreshonly exec, chained so it runs when foreman::install::repos/extras changes.

#2 Updated by Kris Buytaert over 5 years ago

Deployment was twice on a fresh box where there were not SCL repos defined before the foremaninstaller started it's work.

#3 Updated by Dominic Cleal over 5 years ago

Error Downloading Packages:
  ruby193-ruby-1.9.3.484-49.el6.centos.alt.x86_64: failure: ruby193/ruby193-ruby-1.9.3.484-49.el6.centos.alt.x86_64.rpm from scl: [Errno 256] No more mirrors to try.
  ruby193-ruby-libs-1.9.3.484-49.el6.centos.alt.x86_64: failure: ruby193/ruby193-ruby-libs-1.9.3.484-49.el6.centos.alt.x86_64.rpm from scl: [Errno 256] No more mirrors to try.
  1:ruby193-rubygem-actionmailer-3.2.8-1.el6.centos.alt.noarch: failure: ruby193/ruby193-rubygem-actionmailer-3.2.8-1.el6.centos.alt.noarch.rpm from scl: [Errno 256] No more mirrors to try.
  ruby193-ruby-irb-1.9.3.484-49.el6.centos.alt.noarch: failure: ruby193/ruby193-ruby-irb-1.9.3.484-49.el6.centos.alt.noarch.rpm from scl: [Errno 256] No more mirrors to try.

#4 Updated by Michael Moll about 3 years ago

can this be closed? I think it's either solved by now or out of scope...

#5 Updated by Ewoud Kohl van Wijngaarden over 2 years ago

  • Status changed from New to Rejected

I agree this can be closed now.

Also available in: Atom PDF