Project

General

Profile

Bug #8848

Content host errata results in error

Added by Justin Sherrill over 7 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
High
Category:
API
Target version:
Difficulty:
easy
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

When trying to view errata for a content host, an error is thrown:

Processing by Katello::Api::V2::SystemsController#errata as JSON
  Parameters: {"page"=>"1", "search"=>"", "api_version"=>"v2", "id"=>"3f76eed9-731f-42e3-947c-fed544bdfedd"}
  Rendered /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.1.0/app/views/katello/api/v2/organizations/show.json.rabl (341.5ms)
Completed 200 OK in 349ms (Views: 336.8ms | ActiveRecord: 6.4ms)
  Rendered /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.1.0/app/views/katello/api/v2/systems/errata.json.rabl within katello/api/v2/layouts/collection (1094.5ms)
NoMethodError: undefined method `key?' for #<JSON::Ext::Generator::State:0x007f770142dbf8>
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/core_ext/object/try.rb:36:in `try'
/opt/rh/ruby193/root/usr/share/gems/gems/activemodel-3.2.8/lib/active_model/serializers/json.rb:91:in `as_json'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/json/encoding.rb:55:in `block in as_json'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/json/encoding.rb:77:in `check_for_circular_references'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/json/encoding.rb:54:in `as_json'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/json/encoding.rb:215:in `block in as_json'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/json/encoding.rb:215:in `map'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/json/encoding.rb:215:in `as_json'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/json/encoding.rb:47:in `block in encode'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/json/encoding.rb:77:in `check_for_circular_references'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/json/encoding.rb:46:in `encode'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/json/encoding.rb:31:in `encode'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/core_ext/object/to_json.rb:16:in `to_json'
/opt/rh/ruby193/root/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/associations/collection_proxy.rb:89:in `method_missing'
/opt/rh/ruby193/root/usr/share/gems/gems/json-1.5.5/lib/json/common.rb:216:in `generate'
/opt/rh/ruby193/root/usr/share/gems/gems/json-1.5.5/lib/json/common.rb:216:in `generate'
/opt/rh/ruby193/root/usr/share/gems/gems/json-1.5.5/lib/json/common.rb:352:in `dump'
/opt/rh/ruby193/root/usr/share/gems/gems/rabl-0.9.0/lib/rabl/engine.rb:240:in `format_json'
/opt/rh/ruby193/root/usr/share/gems/gems/rabl-0.9.0/lib/rabl/engine.rb:64:in `to_json'
/opt/rh/ruby193/root/usr/share/gems/gems/rabl-0.9.0/lib/rabl/engine.rb:39:in `block in render'
/opt/rh/ruby193/root/usr/share/gems/gems/rabl-0.9.0/lib/rabl/engine.rb:285:in `cache_results'
/opt/rh/ruby193/root/usr/share/gems/gems/rabl-0.9.0/lib/rabl/engine.rb:39:in `render'
/opt/rh/ruby193/root/usr/share/gems/gems/katello-2.1.0/app/views/katello/api/v2/systems/errata.json.rabl:1:in `__opt_rh_ruby____root_usr_share_gems_gems_katello_______app_views_katello_api_v__systems_errata_json_rabl__2532825017284080550_70074541047440'
/opt/rh/ruby193/root/usr/share/gems/gems/actionpack-3.2.8/lib/action_view/template.rb:145:in `block in render'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/notifications.rb:125:in `instrument'

Associated revisions

Revision a878e89e (diff)
Added by Justin Sherrill over 7 years ago

fixes #8848 - fixing content host errata list

this may be a production only issue, but due to sending the AR record to be decoded to json
an error was thrown. The solution is to send the cve name which is what was intended

Revision ddeae407
Added by Justin Sherrill over 7 years ago

Merge pull request #4900 from jlsherrill/8848

fixes #8848 - fixing content host errata list

History

#1 Updated by The Foreman Bot over 7 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/4900 added
  • Pull request deleted ()

#2 Updated by Justin Sherrill over 7 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#3 Updated by Stephen Benjamin over 7 years ago

  • Bugzilla link set to 1169946

Also available in: Atom PDF