Project

General

Profile

Bug #8916

The Foreman installer should not destroy /etc/httpd/conf*

Added by Trevor Vaughan almost 7 years ago. Updated over 1 year ago.

Status:
Rejected
Priority:
High
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

The foreman-installer script eliminates all httpd configuration data from /etc/httpd/conf*.

Mode: Configure foreman is the only item checked in the interactive configuration menu.

Expectation, I should be able to install the Foreman on an existing system without the destruction of existing data.

Marking as High due to the unexpected destruction of system configuration data.

History

#1 Updated by Trevor Vaughan over 6 years ago

Hi all,

Any update here? It would be really nice not to have my apache config get destroyed at random with no warning.

#2 Updated by Dominic Cleal over 6 years ago

This is the default behaviour of the apache module that we use, which we can't easily influence right now. Perhaps if we can start managing its class parameters we can expose options to prevent it purging, but that isn't possible with kafo as the class is undocumented.

#3 Updated by Anonymous over 4 years ago

  • Status changed from New to Rejected

works as designed.

#4 Updated by E.S. Rosenberg over 1 year ago

I can understand that due to limitations of what is being used this is unavoidable, what I can't understand though is why the installer does not prompt and warn that this is about to happen before being destructive.
I just ran foreman-installer on a server that was already providing a service (granted in it's testing phase) and am less then amused that all apache configs were destroyed without ever being warned ahead of time that this process would be destructive.

It would seem that adding a warning prompt at the beginning of the process allowing premature stopping would be wise.

Also available in: Atom PDF