Project

General

Profile

Bug #9588

foreman-installer should be able to work with puppet enterprise

Added by Corey Osman over 7 years ago. Updated about 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
RPMs
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

The foreman installer currently install its own version of puppet (minimum of 2.7) even though PE is already installed. The RPM spec should not install the puppet open source if puppet enterprise is installed.

There needs to be some conditional logic around the dependency.

https://github.com/theforeman/foreman-packaging/blob/rpm/develop/foreman-installer/foreman-installer.spec#L26

Puppet Enterprise buts the puppet binary in /opt/puppet/bin/


Related issues

Related to Foreman - Tracker #8447: Puppet 4 supportClosed2014-11-19

Is duplicate of Installer - Bug #9803: unable to use the installer on a system with puppet peRejected2015-03-18

History

#1 Updated by Corey Osman over 7 years ago

  • Subject changed from foreman-install should be able to work with puppet enterprise to foreman-installer should be able to work with puppet enterprise

#2 Updated by Dominic Cleal over 7 years ago

Yeah, I'm not aware of any way to do this unless PE can "provide" something that's identical to the OSS version. We'll also need to change the smart proxy and other things so they can load the PE version... this might be easier once we do the Puppet 4 work in #8447 as the Puppet 4 packaging is very similar to PE.

#3 Updated by Dominic Cleal over 7 years ago

#4 Updated by Anonymous about 5 years ago

This should be much easier now with Aio packages being supported, just somebody needs to do it (mainly Pupet module work)

#5 Updated by Anonymous about 5 years ago

  • Is duplicate of Bug #9803: unable to use the installer on a system with puppet pe added

#6 Updated by Anonymous about 5 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF