Project

General

Profile

Bug #974

Error getting puppet classes assigned to an environment

Added by Jacob McCann over 11 years ago. Updated over 11 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

When looking at environments in foreman via "Settings" > "Environments" and clicking the "classes" link for a specific environment I get an error:

Unsupported query object: {"environments_id_equals"=>"3"}!

Also, the search box has a query of:

environments_id_equals3

From my production.log:

Processing PuppetclassesController#index (for 56.192.77.203 at 2011-06-09 14:21:39) [GET]
Parameters: {"search"=>{"environments_id_equals"=>"3"}}
Rendering template within layouts/application
Rendering puppetclasses/index
Completed in 392ms (View: 371, DB: 7) | 200 OK [https://eagnmnmepf48.usps.gov/puppetclasses?search[environments_id_equals]=3]


Related issues

Is duplicate of Foreman - Bug #984: Display Error on environments->classes linkClosed2011-06-14

History

#1 Updated by Ohad Levy over 11 years ago

  • Status changed from New to Feedback

I think this was fixed a while ago as part of another ticket, is it still relevant?

#2 Updated by Jacob McCann over 11 years ago

How would I test? I'm using 0.3 and am running into this issue still, but I haven't updated at all since I encountered it. Do I just grab http://theforeman.org/foreman-nightly.tar.bz2 and try again?

#3 Updated by Ohad Levy over 11 years ago

  • Status changed from Feedback to Duplicate

this is actually a duplicate of #984

Also available in: Atom PDF