Project

General

Profile

Bug #10888

duplicate interfaces when using bond device

Added by Sven Vogel over 5 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Network
Target version:
Difficulty:
medium
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Hi,

when we create a bond device with kickstart we get duplicate interfaces. we thinks its not correct handling of bond and the same mac addresses.

normally the bond master and slaves have the same mac. it there a fix in the future?

thanks

Sven

error.png View error.png 31.8 KB Sven Vogel, 06/20/2015 09:08 AM
Error

Related issues

Related to Foreman - Bug #10546: Reduce the number of interfaces duplicatesDuplicate2015-05-19
Related to Foreman - Bug #10805: VLAN interface attached to bond is wrongly created as BondClosed2015-06-13
Related to Foreman - Bug #10607: bonding on ubuntu causes foreman to create an interface after each ubuntu server rebootClosed2015-05-26

Associated revisions

Revision db6d6b8b (diff)
Added by Marek Hulán over 5 years ago

Fixes #10888 - skip attached_to updates if identifier was blank

Revision b094575d (diff)
Added by Marek Hulán over 5 years ago

Fixes #10888 - skip attached_to updates if identifier was blank

(cherry picked from commit db6d6b8b7d0d2e90e27d4c23308e5db26abd3820)

Revision 66a5487c (diff)
Added by Marek Hulán over 5 years ago

Fixes #10888 - skip attached_to updates if identifier was blank

(cherry picked from commit db6d6b8b7d0d2e90e27d4c23308e5db26abd3820)

History

#1 Updated by Sven Vogel over 5 years ago

macaddress_bond0 => 00:19:99:cb:c2:e2

macaddress_enp8s0f0 => 00:19:99:9e:41:08

macaddress_enp8s0f1 => 00:19:99:9e:41:09

macaddress_ens5f0 => 00:19:99:99:16:1a

macaddress_ens5f1 => 00:19:99:99:16:1b

macaddress_ens5f2 => 00:19:99:99:16:1c

macaddress_ens5f3 => 00:19:99:99:16:1d

macaddress_ens7f0 => 00:19:99:CB:C2:E2

macaddress_ens7f1 => 00:19:99:CB:C2:E3

puppet will do it correct but foreman should seperate the bond0 from it slaves,

#2 Updated by Marek Hulán over 5 years ago

Could you please upload full output of facter? Feel free to remove sensitive information, I'm mostly interested in interfaces and mac_* facts. Are all of interfaces (except bond) physical or do you use vlans/aliases? It might be related to #10805 and #10546

#3 Updated by Marek Hulán over 5 years ago

  • Related to Bug #10546: Reduce the number of interfaces duplicates added

#4 Updated by Marek Hulán over 5 years ago

  • Related to Bug #10805: VLAN interface attached to bond is wrongly created as Bond added

#5 Updated by Marek Hulán over 5 years ago

  • Status changed from New to Assigned
  • Assignee set to Marek Hulán

I think I found the cause. The issue is that bond is virtual interface which is attached_to ''. When physical interface identifier changes we modify all virtual interfaces of host that has attached_to set to previous identifier value. Since bond is usually imported (and persisted) before primary interface, when primary interface identifier is set for the first time (after provisioning) its identifier changes from '' to 'ens7f0' and we change bond's attached_to from '' to 'ens7f0' and then we even change the identifier (that is required for vlans and aliases). So we have to skip changes where original identifier was not set. Not sure if this also solves the duplication issue (could be) but I'll look at that in #10607

#6 Updated by The Foreman Bot over 5 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/2485 added
  • Pull request deleted ()

#7 Updated by Marek Hulán over 5 years ago

  • Related to Bug #10607: bonding on ubuntu causes foreman to create an interface after each ubuntu server reboot added

#8 Updated by Dominic Cleal over 5 years ago

  • Legacy Backlogs Release (now unused) set to 62

#9 Updated by Marek Hulán over 5 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF