Project

General

Profile

Bug #11146

hammer cli needs options for server_type and groups_base for auth_source_ldap

Added by Bryan Kearney about 4 years ago. Updated about 4 years ago.

Status:
Duplicate
Priority:
High
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1242527
Description of problem:

Currently we have no options from cli to provide server_type and groups_base for auth_source_ldap

  1. hammer -u admin -p changeme auth-source ldap create --help
    Usage:
    hammer auth-source ldap create [OPTIONS]

Options:
--account ACCOUNT
--account-password ACCOUNT_PASSWORD required if onthefly_register is true
--attr-firstname ATTR_FIRSTNAME required if onthefly_register is true
--attr-lastname ATTR_LASTNAME required if onthefly_register is true
--attr-login ATTR_LOGIN required if onthefly_register is true
--attr-mail ATTR_MAIL required if onthefly_register is true
--attr-photo ATTR_PHOTO
--base-dn BASE_DN
--host HOST
--name NAME
--onthefly-register ONTHEFLY_REGISTER One of true/false, yes/no, 1/0.
--port PORT defaults to 389
--tls TLS One of true/false, yes/no, 1/0.
-h, --help print help

Version-Release number of selected component (if applicable):
with sat6-GA-snap11-c2

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:
no options to specify "server_type" or ""groups_base"

Expected results:
We should be able to specify these options.

Additional info:


Related issues

Is duplicate of Foreman - Bug #11033: hammer auth-source does not allow all the settingsClosed2015-07-07

History

#1 Updated by Dominic Cleal about 4 years ago

  • Is duplicate of Bug #11033: hammer auth-source does not allow all the settings added

#2 Updated by Dominic Cleal about 4 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF